Bug 465496 - Missing Dependency: rhino
Missing Dependency: rhino
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhino (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wringe
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 11:35 EDT by ajs
Modified: 2008-10-03 11:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 11:55:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ajs 2008-10-03 11:35:37 EDT
Description of problem:
java-1.6.0-openjdk-1.6.0.0-0.18.b09.fc9.x86_64 in the updates-newkey repository requires rhino, but rhino is not in the updates-newkey repository.

How reproducible:
always

Steps to Reproduce:
1. 
2. sudo yum update java-1.6.0-openjdk
3.
  
Actual results:
[ ~]$ sudo yum --disablerepo=* --enablerepo=*-newkey update java-1.6.0-openjdk
Loaded plugins: refresh-packagekit
updates-newkey                                                                                                                     | 2.3 kB     00:00     
primary.sqlite.bz2                                                                                                                 | 3.4 MB     00:08     
updates-testing-newkey                                                                                                             | 2.3 kB     00:00     
primary.sqlite.bz2                                                                                                                 | 416 kB     00:01     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: java-1.6.0-openjdk = 1:1.6.0.0-0.16.b09.fc9 for package: java-1.6.0-openjdk-plugin
---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-0.18.b09.fc9 set to be updated
--> Processing Dependency: rhino for package: java-1.6.0-openjdk
--> Running transaction check
---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-0.18.b09.fc9 set to be updated
--> Processing Dependency: rhino for package: java-1.6.0-openjdk
---> Package java-1.6.0-openjdk-plugin.x86_64 1:1.6.0.0-0.18.b09.fc9 set to be updated
--> Finished Dependency Resolution
1:java-1.6.0-openjdk-1.6.0.0-0.18.b09.fc9.x86_64 from updates-newkey has depsolving problems
  --> Missing Dependency: rhino is needed by package 1:java-1.6.0-openjdk-1.6.0.0-0.18.b09.fc9.x86_64 (updates-newkey)
Error: Missing Dependency: rhino is needed by package 1:java-1.6.0-openjdk-1.6.0.0-0.18.b09.fc9.x86_64 (updates-newkey)


Expected results:
clean update

Additional info:
Comment 1 Matt Wringe 2008-10-03 11:55:13 EDT
Thats because there hasn't been an update for Rhino in Fedora 9, so it wont be in any update repo.
Closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.