Bug 465519 - Mouse wheel doesn't work using apple bluetooth mighty mouse
Mouse wheel doesn't work using apple bluetooth mighty mouse
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 13:49 EDT by Jeff Sheltren
Modified: 2008-10-13 17:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-13 17:43:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Sheltren 2008-10-03 13:49:25 EDT
Description of problem:
Using a bluetooth "mighty mouse", it connects fine to bluetooth, left, right, middle buttons are working, but the scroll wheel doesn't work either horizontally or vertically.

Version-Release number of selected component (if applicable):
bluez-4.9-1.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Login to gnome
2. Open window which has a scrollbar
3. Try to scroll with scroll wheel on mouse
  
Actual results:
No scrolling

Expected results:
Should scroll when using mouse scroll wheel

Additional info:
Running rawhide on an intel mac mini.  No xorg.conf is present.
Comment 1 Bastien Nocera 2008-10-03 18:39:13 EDT
Does using the scroll button on a running xev window show any button events?

If not, could you try running evtest on the different input devices. eg.:
evtest /dev/input/event0
evtest /dev/input/event1
etc.

I'm looking for everything before "Testing ... (interrupt to exit)". It should print out the name of the device, and information about what it can do.

You can get a copy of evtest.c from google, and compile it using "gcc -o evtest evtest.c".
Comment 2 Jeff Sheltren 2008-10-03 19:09:26 EDT
Scrolling in an xev window doesn't show any output.

Here's the output of evtest with the two events that are mouse-related:

# evtest /dev/input/event2
Input driver version is 1.0.0
Input device ID: bus 0x17 vendor 0x1 product 0x1 version 0x100
Input device name: "Macintosh mouse button emulation"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 272 (LeftBtn)
    Event code 273 (RightBtn)
    Event code 274 (MiddleBtn)
  Event type 2 (Relative)
    Event code 0 (X)
    Event code 1 (Y)

# evtest /dev/input/event4
Input driver version is 1.0.0
Input device ID: bus 0x3 vendor 0x5ac product 0x1000 version 0x111
Input device name: "HID 05ac:1000"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 272 (LeftBtn)
    Event code 273 (RightBtn)
    Event code 274 (MiddleBtn)
    Event code 275 (SideBtn)
    Event code 276 (ExtraBtn)
  Event type 2 (Relative)
    Event code 0 (X)
    Event code 1 (Y)
  Event type 4 (Misc)
    Event code 4 (ScanCode)
Comment 3 Bastien Nocera 2008-10-07 11:00:56 EDT
It should also have:
    Event code 6 (HWheel)
    Event code 8 (Wheel)
in there.

Could be a problem with the HID report not being correct.
Comment 4 Bastien Nocera 2008-10-07 15:27:41 EDT
Could you tell me the output of "hidd --show" with the mouse connected and "working"?
Comment 5 Jeff Sheltren 2008-10-07 15:33:53 EDT
The command hidd --show doesn't output anything for me.
Comment 6 Bastien Nocera 2008-10-07 16:01:06 EDT
"hidd --show" needs to be run when the mouse is connected to the computer via Bluetooth, otherwise it won't show anything.
Comment 7 Jeff Sheltren 2008-10-07 16:34:39 EDT
I am using both the bluetooth mouse and bluetooth keyboard at the moment, but 'hidd --show' doesn't output anything.

[root@sakic ~]# hidd --show
[root@sakic ~]#
Comment 8 Bastien Nocera 2008-10-13 08:18:42 EDT
Are you using a Mac by any chance?
Comment 9 Jeff Sheltren 2008-10-13 09:38:00 EDT
Yes, this is on a Mac Mini (Intel C2D).
Comment 10 Bastien Nocera 2008-10-13 10:25:10 EDT
The reason why "hidd --show" doesn't show anything is because you're not using Bluetooth. You can double-check it using "hciconfig" (shouldn't show any Bluetooth devices).

You'll need to turn on hid2hci (see /etc/sysconfig/bluetooth), and pair the devices using bluez-gnome for now (your Bluetooth devices will stop working for a short while).

In the future, bluetoothd will have code to do all that automatically.
Comment 11 Jeff Sheltren 2008-10-13 17:03:21 EDT
Ahh, it's like "when is a bluetooth mouse not a bluetooth mouse?" :)

Thanks for the catch.  I've made the changes you suggested and things are working now, including the mouse wheel.  After a reboot, I didn't have keyboard/mouse for the login screen, but after logging in with a usb keyboard/mouse, I was able to re-connect to the bluetooth ones.  That may be a different issue, so feel free to close out this ticket.  Thanks again!

Note You need to log in before you can comment on or make changes to this bug.