Bug 465605 - IrDA connections not working with Nokia 6021
IrDA connections not working with Nokia 6021
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-04 08:32 EDT by Daniel Qarras
Modified: 2009-04-02 18:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 18:23:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
irda syslog info on F9 (909 bytes, text/plain)
2008-10-04 08:35 EDT, Daniel Qarras
no flags Details
gnokii output on F9 (4.43 KB, text/plain)
2008-10-04 08:35 EDT, Daniel Qarras
no flags Details
irda syslog info on F10Beta (911 bytes, text/plain)
2008-10-04 08:40 EDT, Daniel Qarras
no flags Details
gnokii output on F10Beta (1.12 KB, text/plain)
2008-10-04 08:41 EDT, Daniel Qarras
no flags Details

  None (edit)
Description Daniel Qarras 2008-10-04 08:32:00 EDT
Description of problem:
With F9 IrDA connections with Nokia 6021 used to work nicely but with F10Beta no more. Not quite sure is this problem in gnokii or kernel or elsewhere but at least it is reproducible.

Version-Release number of selected component (if applicable):
gnokii-0.6.26-3.fc10.i386
irda-utils-0.9.18-5.fc10.i386
kernel-2.6.27-0.382.rc8.git4.fc10.i686

How reproducible:
Always.

Steps to Reproduce:
1. Start irda service, adjust needed IrDA connection parameters
2. Run "gnokii --identify"
3. See failure/success
  
Actual results:
gnokii can't create connection.

Expected results:
gnokii identifies the phone.

Additional info:
I'm following this procedure on both F9/F10Beta and F9 is ok, F10Beta fails.

service irda start
echo 115200 > /proc/sys/net/irda/max_baud_rate
echo 2000 > /proc/sys/net/irda/max_tx_data_size
echo 1000 > /proc/sys/net/irda/min_tx_turn_time
echo 1 > /proc/sys/net/irda/max_tx_window

root@localhost:~# cat /etc/gnokiirc
[global]
port = /dev/ircomm0
model = AT
initlength = default
connection = serial

[logging]
debug = on

I'll attach some logs from gnokii both from F9/F10Beta.

Please let me know if more information is needed.
Comment 1 Daniel Qarras 2008-10-04 08:35:22 EDT
Created attachment 319456 [details]
irda syslog info on F9
Comment 2 Daniel Qarras 2008-10-04 08:35:46 EDT
Created attachment 319457 [details]
gnokii output on F9
Comment 3 Daniel Qarras 2008-10-04 08:40:47 EDT
Created attachment 319460 [details]
irda syslog info on F10Beta
Comment 4 Daniel Qarras 2008-10-04 08:41:09 EDT
Created attachment 319461 [details]
gnokii output on F10Beta
Comment 5 Daniel Qarras 2008-10-04 08:43:01 EDT
And FWIW, I also get the same results with the native 6021 (ie 6510) gnokii driver.
Comment 6 Daniel Qarras 2008-10-27 15:16:40 EDT
Still problem with these versions:

gnokii-0.6.27-2.fc10.i386
irda-utils-0.9.18-5.fc10.i386
kernel-2.6.27.4-51.fc10.i686
Comment 7 Daniel Qarras 2008-11-03 09:22:50 EST
I will lose the hardware in a week or so I'm not able to test/debug after that.

Thanks.
Comment 8 Bug Zapper 2008-11-25 22:32:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Daniel Qarras 2008-12-14 10:03:29 EST
Actually this is not a gnokii problem, irdadump does not show anything coming back from the phone. On F9 it worked. Might be a kernel problem, I'll see if I can set up F9 for testing at some point.
Comment 10 Daniel Qarras 2009-01-04 09:24:39 EST
This seems to be a Fedora kernel issue, I compiled 2.6.2{4,6,8} from kernel.org on F10 and IrDA worked all ok with all them, so only with F10 kernels I'm seeing IrDA connections to fail.
Comment 11 Daniel Qarras 2009-04-02 18:23:41 EDT
This is fixed in F11 Beta. Closing.

Note You need to log in before you can comment on or make changes to this bug.