Bug 465656 - symlinks for man pages accidently created in /usr/bin
symlinks for man pages accidently created in /usr/bin
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: groff (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-05 04:44 EDT by Christian Krause
Modified: 2008-11-07 05:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 05:53:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for groff spec file to fix the problem (641 bytes, patch)
2008-10-05 04:44 EDT, Christian Krause
no flags Details | Diff

  None (edit)
Description Christian Krause 2008-10-05 04:44:47 EDT
Created attachment 319492 [details]
patch for groff spec file to fix the problem

Description of problem:
The symlinks for some man pages (e.g. gpic.1.gz) are accidently created in /usr/bin instead of /usr/share/man/man1/ . 

Version-Release number of selected component (if applicable):
groff-1.18.1.4-15

How reproducible:
100%

Steps to Reproduce:
1. install groff
2. try "man gpic"
3. ls -la /usr/bin/gpic*
  
Actual results:
no manual found for gpic (should be the same as for pic)
gpic.1.gz symlink in /usr/bin

Expected results:
symlinks for man pages should be in /usr/share/man/man1

Additional info:
The problem is caused by a typo in the spec file, I've attached a patch to fix it.
Comment 1 Christian Krause 2008-11-06 08:49:30 EST
*ping*
Any news regarding this issue? Is there anything more I can do to help to fix this problem?
Comment 2 Till Maas 2008-11-06 18:09:58 EST
(In reply to comment #1)
> *ping*
> Any news regarding this issue? Is there anything more I can do to help to fix
> this problem?

This has been fixed in groff-1.18.1.4-16.fc10 which will be in F10 Everything.

https://koji.fedoraproject.org/koji/packageinfo?packageID=1019


It set this to ASSIGNED, because no further triaging needs to be done. Probably this can be closed, unless some also wants to push an update for F9 (it this bug is present there, too).
Comment 3 Christian Krause 2008-11-07 05:53:35 EST
Thank you very much.
I'd like to confirm that groff-1.18.1.4-16.fc10.i386 fixes the problem for F10.

The most recent package in F9 is groff-1.18.1.4-14.fc9.i386 which doesn't have this problem.

So everything seems to be fine in F9 and F10 and so I'm suggesting to close this bug with the resolution RAWHIDE. (Btw: would it be OK if I as the reporter close the bug?)

Note You need to log in before you can comment on or make changes to this bug.