Bug 465659 - swfdec 0.9 and newer -- no sound on YouTube videos [regression]
swfdec 0.9 and newer -- no sound on YouTube videos [regression]
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: swfdec-mozilla (Show other bugs)
12
All Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Kowaliczek
Fedora Extras Quality Assurance
: Triaged
: 489247 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-05 06:16 EDT by Vedran Miletić
Modified: 2010-03-16 17:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-16 17:48:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vedran Miletić 2008-10-05 06:16:29 EDT
Description of problem:
When playing youtube videos, there is a lot of noise (crackling), unrelated to whether pulseaudio is activer or not.
nspluginwrapper was uninstalled.

Version-Release number of selected component (if applicable):
swfdec-0.8.0-1.fc10.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Open any youtube video, for example http://www.youtube.com/watch?v=p97ctSDMmgg
2. Listen.
  
Actual results:
Lots of crackling.

Expected results:
No crackling.

Additional info:
It happens on both soundcards I have (onboard HDA NVidia + Realtek ALC662) and E-mu 1212m).
Comment 1 Vedran Miletić 2008-10-05 06:30:11 EDT
Sorry, I didn't notice that opening youtube video made pulseaudio run again. This is a pulseaudio issue too. With

realtime-scheduling = yes (dom't know what this does, but looks good)
resample-method = speex-float-9
default-fragment-size-msec = 50

there is almost no crackling most of the time. Please assign this to pulseaudio, as I can't do it.
Comment 2 Brian Pepple 2008-10-27 14:33:54 EDT
Are you still experiencing this bug w/ swfdec-0.8.2?
Comment 3 Bug Zapper 2008-11-25 22:34:15 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Pedro Matiello 2008-12-04 14:49:37 EST
I can confirm the issue here using swfdec-0.8.2 and pulseaudio-0.9.13-6.
Comment 5 Vedran Miletić 2008-12-31 14:52:56 EST
Still happens with whatever is current version of everything in F10.
Comment 6 Brian Pepple 2009-04-05 10:13:36 EDT
*** Bug 489247 has been marked as a duplicate of this bug. ***
Comment 7 Joshua Roys 2009-05-07 15:28:08 EDT
For both this and bug 489247, I know that the only version of swfdec that can play h264 videos (or at least the audio from them) is 0.8.4.  0.9.2 can't.  See http://lists.freedesktop.org/archives/swfdec/2008-December/002276.html .  And http://cgit.freedesktop.org/swfdec/swfdec/log/ .  I'm on latest rawhide, and youtube audio = fail.

SWFDEC: ERROR: swfdec_audio_decoder.c(203): swfdec_audio_decoder_errorv: error decoding audio: no suitable decoder for audio codec 10

# rpm -qa swfdec*
swfdec-mozilla-0.9.2-2.fc11.x86_64
swfdec-0.9.2-2.fc11.x86_64
swfdec-gtk-0.9.2-2.fc11.x86_64
swfdec-gnome-2.26.0-1.fc11.x86_64
# rpm -qa gst\*
gstreamer-plugins-farsight-0.12.10-2.fc11.x86_64
gstreamer-tools-0.10.22-3.fc11.x86_64
gstreamer-plugins-base-0.10.22-2.fc11.x86_64
gstreamer-python-0.10.14-2.fc11.x86_64
gstreamer-ffmpeg-0.10.7-1.fc11.x86_64
gstreamer-plugins-bad-0.10.11-4.fc11.x86_64
gstreamer-plugins-ugly-0.10.11-1.fc11.x86_64
gstreamer-plugins-flumpegdemux-0.10.15-6.fc11.x86_64
gstreamer-plugins-good-0.10.14-2.fc11.x86_64
gstreamer-0.10.22-3.fc11.x86_64
# rpm -qa pulse\*
pulseaudio-module-gconf-0.9.15-11.fc11.x86_64
pulseaudio-module-x11-0.9.15-11.fc11.x86_64
pulseaudio-esound-compat-0.9.15-11.fc11.x86_64
pulseaudio-libs-zeroconf-0.9.15-11.fc11.x86_64
pulseaudio-0.9.15-11.fc11.x86_64
pulseaudio-utils-0.9.15-11.fc11.x86_64
pulseaudio-libs-glib2-0.9.15-11.fc11.x86_64
pulseaudio-libs-0.9.15-11.fc11.x86_64
Comment 8 Vedran Miletić 2009-08-26 08:16:58 EDT
This is still the case.
Comment 9 Vedran Miletić 2009-11-01 03:24:14 EST
This hasn't changed at all in rawhide. Brian, any ideas?
Comment 10 Bug Zapper 2009-11-16 04:29:33 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Thomas Kowaliczek 2010-03-16 17:48:03 EDT
SWFDEC Upstream is dead this package will die with F-12 and will be not in F-13.

Note You need to log in before you can comment on or make changes to this bug.