Bug 465705 - Libspe should symlink /usr/lib/libspe2.so to /usr/lib/libspe.2.so.2
Libspe should symlink /usr/lib/libspe2.so to /usr/lib/libspe.2.so.2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libspe2 (Show other bugs)
9
ppc64 Linux
medium Severity low
: ---
: ---
Assigned To: Jochen Roth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-05 16:00 EDT by Aidan Delaney
Modified: 2008-10-06 04:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 04:20:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aidan Delaney 2008-10-05 16:00:20 EDT
Description of problem:
When compiling an application it's reasonable to supply -lspe2 as a library to link against.  As there's no symlink from /usr/lib/libspe2.so to /usr/lib/libspe.2.so.2 compilation fails.

Third party SPU applications (genearlly built against the IBM SDK) assume that -lspe2 works.
Comment 1 Jochen Roth 2008-10-06 04:20:58 EDT
The libspe2.so symbolic link is available in the libspe2-devel package. You have to install the -devel packages in order to develop applications.

Note You need to log in before you can comment on or make changes to this bug.