Bug 465723 - PackageKit-gstreamer-plugin-0.3.5-4.fc10 conflicts with gst-install-plugins-helper from codeina-0.10.1-9.fc10
PackageKit-gstreamer-plugin-0.3.5-4.fc10 conflicts with gst-install-plugins-h...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-05 22:53 EDT by sangu
Modified: 2008-10-07 11:31 EDT (History)
6 users (show)

See Also:
Fixed In Version: 0.3.6-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 11:31:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-10-05 22:53:10 EDT
Description of problem:
PackageKit-gstreamer-plugins-0.3.5-4fc10 conflicts with gst-install-plugins-helper from codeina-0.10.1-9.fc10

$ yum install PackageKit-gstreamer-plugin
Loaded plugins: downloadonly, refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package PackageKit-gstreamer-plugin.i386 0:0.3.5-4.fc10 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                         Arch     Version          Repository     Size 
================================================================================
Installing:
 PackageKit-gstreamer-plugin     i386     0.3.5-4.fc10     rawhide         51 k

Transaction Summary
================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total size: 51 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/libexec/gst-install-plugins-helper from install of PackageKit-gstreamer-plugin-0.3.5-4.fc10.i386 conflicts with file from package codeina-0.10.1-9.fc10.noarch

Error Summary
-------------


Version-Release number of selected component (if applicable):
0.3.5-4.fc10

How reproducible:
always

Steps to Reproduce:
1. Install PackageKit-gstreamer-plugins-0.3.5-4.fc10
2.
3.
  
Actual results:


Expected results:


Additional info:
codeina-0.10.1-9.fc10
Comment 1 Richard Hughes 2008-10-06 04:27:23 EDT
I've got this in the spec file:

Obsoletes: codeina < 0.10.1
Provides:  codeina = 0.10.1

Is that not going to match?
Comment 2 sangu 2008-10-06 04:53:59 EDT
(In reply to comment #1)
> I've got this in the spec file:
> 
> Obsoletes: codeina < 0.10.1
> Provides:  codeina = 0.10.1
> 
> Is that not going to match?

Current codeina version is 0.10.1-9.fc10 in rawhide.

So, 0.10.2 than 0.10.1?

Obsoletes: codeina < 0.10.2
Provides:  codeina = 0.10.2
Comment 3 Richard Hughes 2008-10-06 06:42:33 EDT
Can you try PackageKit-0.3.6-2 in rawhide please? Thanks.
Comment 4 Matt Domsch 2008-10-06 09:05:17 EDT
0.10.1 is < 0.10.1-9.fc10  by RPM's version comparison math.

Provides: codeina = 0.10.1-10.fc10
Obsoletes: codeina < 0.10.1-10.fc10

unless you have a 0.10.2 release, or know none such or greater will ever exist.

Note You need to log in before you can comment on or make changes to this bug.