Bug 465724 - mock caches no longer work
mock caches no longer work
Status: CLOSED DUPLICATE of bug 458234
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-05 23:20 EDT by Kevin Fenzi
Modified: 2013-01-09 23:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 11:09:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2008-10-05 23:20:47 EDT
On trying to use a mock cache, the first build to try and use it gets: 

...
error: db4 error(2) from dbcursor->c_get: No such file or directory
error: db4 error(2) from dbcursor->c_get: No such file or directory
error: db4 error(2) from dbcursor->c_get: No such file or directory
error: db4 error(2) from dbcursor->c_get: No such file or directory
error: error(2) getting "libc.so.6(GLIBC_2.3)(64bit)" records from Providename index
error: db4 error(2) from dbcursor->c_get: No such file or directory
error: error(2) getting "env" records from Basenames index
error: db4 error(2) from dbcursor->c_get: No such file or directory
python-2.5.2-1.fc10.x86_64 from fedora has depsolving problems
  --> Missing Dependency: /usr/bin/env is needed by package python-2.5.2-1.fc10.x86_64 (fedora)
python-2.5.2-1.fc10.x86_64 from fedora has depsolving problems
  --> Missing Dependency: libc.so.6(GLIBC_2.3)(64bit) is needed by package python-2.5.2-1.fc10.x86_64 (fedora)

Builds without caching or where they generate the cache work fine. 

It seems to happen when mock is trying to add builddeps to the cache/chroot: 

DEBUG util.py:272:  Executing command: /usr/bin/yum --installroot /var/lib/mock/fedora-rawhide-x86_64-pyxattr/root/  resolvedep  ccache  'libattr-devel' 'python-devel'
DEBUG util.py:250:  0:ccache-2.4-13.fc9.x86_64
DEBUG util.py:250:  0:libattr-devel-2.4.43-1.fc10.x86_64
DEBUG util.py:250:  0:python-devel-2.5.2-1.fc10.x86_64
DEBUG util.py:311:  Child returncode was: 0
DEBUG backend.py:496:  /usr/bin/yum --installroot /var/lib/mock/fedora-rawhide-x86_64-pyxattr/root/  install  ccache  'libattr-devel' 'python-devel'
DEBUG util.py:272:  Executing command: /usr/bin/yum --installroot /var/lib/mock/fedora-rawhide-x86_64-pyxattr/root/  install  ccache  'libattr-devel' 'python-devel'
DEBUG util.py:250:  error:
DEBUG util.py:250:  db4 error(2) from dbcursor->c_get: No such file or directory
DEBUG util.py:250:  error:
DEBUG util.py:250:  db4 error(2) from dbcursor->c_get: No such file or directory
DEBUG util.py:250:  error:
DEBUG util.py:250:  db4 error(2) from dbcursor->c_get: No such file or directory
DEBUG util.py:250:  error:
DEBUG util.py:250:  db4 error(2) from dbcursor->c_get: No such file or directory
DEBUG util.py:250:  error:
DEBUG util.py:250:  error(2) getting "libc.so.6(GLIBC_2.3)(64bit)" records from Providename index
DEBUG util.py:250:  error:
DEBUG util.py:250:  db4 error(2) from dbcursor->c_get: No such file or directory
DEBUG util.py:250:  error:
DEBUG util.py:250:  error(2) getting "env" records from Basenames index
DEBUG util.py:250:  error:
DEBUG util.py:250:  db4 error(2) from dbcursor->c_get: No such file or directory

Happy to duplicate/provide further logs/info.
Comment 1 Panu Matilainen 2008-10-15 11:09:19 EDT

*** This bug has been marked as a duplicate of bug 458234 ***

Note You need to log in before you can comment on or make changes to this bug.