Bug 465770 - BUG: soft lockup detected
BUG: soft lockup detected
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 07:15 EDT by Neal Becker
Modified: 2009-03-13 15:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 15:08:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2008-10-06 07:15:37 EDT
Description of problem:
Oct  5 07:05:09 nbecker5 kernel: BUG: soft lockup - CPU#2 stuck for 61s! [updatedb:1442]
Oct  5 07:05:09 nbecker5 kernel: Modules linked in: bridge bnep rfcomm l2cap bluetooth fuse tun sunrpc ipt_REJECT nf_conntrack_ipv4 iptable_filter ip_tables nf_conntrack_netbios_ns ip6t_REJECT xt_tcpudp nf_conntrack_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables x_tables dm_mirror dm_log dm_multipath dm_mod ipv6 kvm_intel kvm snd_hda_intel sr_mod snd_seq_dummy snd_seq_oss cdrom snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer ahci snd_page_alloc snd_hwdep firewire_ohci firewire_core pata_jmicron ppdev pcspkr parport_pc parport r8169 snd crc_itu_t soundcore i2c_i801 iTCO_wdt i2c_core iTCO_vendor_support floppy sg ata_generic pata_acpi ata_piix libata sd_mod scsi_mod raid456 async_xor async_memcpy async_tx xor raid0 ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: freq_table]
Oct  5 07:05:09 nbecker5 kernel: CPU 2:
Oct  5 07:05:09 nbecker5 kernel: Modules linked in: bridge bnep rfcomm l2cap bluetooth fuse tun sunrpc ipt_REJECT nf_conntrack_ipv4 iptable_filter ip_tables nf_conntrack_netbios_ns ip6t_REJECT xt_tcpudp nf_conntrack_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables x_tables dm_mirror dm_log dm_multipath dm_mod ipv6 kvm_intel kvm snd_hda_intel sr_mod snd_seq_dummy snd_seq_oss cdrom snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer ahci snd_page_alloc snd_hwdep firewire_ohci firewire_core pata_jmicron ppdev pcspkr parport_pc parport r8169 snd crc_itu_t soundcore i2c_i801 iTCO_wdt i2c_core iTCO_vendor_support floppy sg ata_generic pata_acpi ata_piix libata sd_mod scsi_mod raid456 async_xor async_memcpy async_tx xor raid0 ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: freq_table]
Oct  5 07:05:09 nbecker5 kernel: Pid: 1442, comm: updatedb Not tainted 2.6.26.3-29.fc9.x86_64 #1
Oct  5 07:05:09 nbecker5 kernel: RIP: 0010:[<ffffffff8129c875>]  [<ffffffff8129c875>] _spin_lock+0x16/0x1a
Oct  5 07:05:09 nbecker5 kernel: RSP: 0018:ffff8102006cdef8  EFLAGS: 00000202
Oct  5 07:05:09 nbecker5 kernel: RAX: 0000000000000105 RBX: ffff8102006cdef8 RCX: ffff8102008eb40c
Oct  5 07:05:09 nbecker5 kernel: RDX: ffffffffffffefff RSI: ffff8100875b9500 RDI: ffff8100ba3b967c
Oct  5 07:05:09 nbecker5 kernel: RBP: 0000000000000002 R08: 0000000000000000 R09: 0000000000000003
Oct  5 07:05:09 nbecker5 kernel: R10: 0000003778367a70 R11: 0000000000000246 R12: 00000000009de43c
Oct  5 07:05:09 nbecker5 kernel: R13: 0000000000000900 R14: ffff8100ba38e340 R15: ffff81022f0c2e00
Oct  5 07:05:09 nbecker5 kernel: FS:  00007fe4fa7256f0(0000) GS:ffff81022fc04c00(0000) knlGS:0000000000000000
Oct  5 07:05:09 nbecker5 kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Oct  5 07:05:09 nbecker5 kernel: CR2: 00007f44dc7b1000 CR3: 000000018da25000 CR4: 00000000000026e0
Oct  5 07:05:09 nbecker5 kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Oct  5 07:05:09 nbecker5 kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Oct  5 07:05:09 nbecker5 kernel:
Oct  5 07:05:09 nbecker5 kernel: Call Trace:
Oct  5 07:05:09 nbecker5 kernel: [<ffffffff810e9e68>] ? dnotify_flush+0x3a/0xa9
Oct  5 07:05:09 nbecker5 kernel: [<ffffffff810aa61d>] ? filp_close+0x53/0x71
Oct  5 07:05:09 nbecker5 kernel: [<ffffffff810aa6d4>] ? sys_close+0x99/0xd2
Oct  5 07:05:09 nbecker5 kernel: [<ffffffff8100c291>] ? tracesys+0xd0/0xd5
Oct  5 07:05:09 nbecker5 kernel:
Oct  5 07:05:14 nbecker5 kernel: INFO: task crond:1596 blocked for more than 120 seconds.
Oct  5 07:05:14 nbecker5 kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Oct  5 07:05:14 nbecker5 kernel: crond         D 7fffffffffffffff     0  1596   2580
Oct  5 07:05:14 nbecker5 kernel: ffff81018cacfd88 0000000000000086 0000000000000000 0000000000000000
Oct  5 07:05:14 nbecker5 kernel: 0000000000000000 ffffffff81583700 ffffffff81583700 ffff81018cb4c3e0
Oct  5 07:05:14 nbecker5 kernel: ffff81022d38c3e0 ffff81018cb4c730 0000000100000000 ffff81018cb4c730
Oct  5 07:05:14 nbecker5 kernel: Call Trace:
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff8129b163>] schedule_timeout+0x22/0xb4
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff811914d4>] ? extract_entropy+0x50/0x97
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff8129b031>] wait_for_common+0xe7/0x13e
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff8102d602>] ? default_wake_function+0x0/0xf
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff8129b112>] wait_for_completion+0x18/0x1a
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff81047e95>] synchronize_rcu+0x35/0x3c
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff81047ebc>] ? wakeme_after_rcu+0x0/0x10
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff81109c8f>] install_session_keyring+0xe6/0xfb
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff81109ccc>] join_session_keyring+0x28/0xcb
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff8110953b>] keyctl_join_session_keyring+0x28/0x2a
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff81109577>] sys_keyctl+0x3a/0xae
Oct  5 07:05:14 nbecker5 kernel: [<ffffffff8100c291>] tracesys+0xd0/0xd5
Oct  5 07:05:14 nbecker5 kernel:

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Carlos Eduardo Maiolino 2009-03-13 12:48:40 EDT
Hi, sorry but we didn't get to this report before now.

If this is a reproducible issue, are you still experiencing it with the latest kernel ? 

If it have been reproducible in the latest kernel, can you provide some more information on what causes the problem to happen ?

I noticed you are using firewire, so, you had a disk mounted, and unplugged it without unmounting or something like that causing updatedb to get stuck ?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Neal Becker 2009-03-13 13:17:19 EDT
I haven't seen this for a long time.

BTW, no I don't have any firewire.
Comment 3 Carlos Eduardo Maiolino 2009-03-13 15:08:19 EDT
"OK, so, since the problem has not reoccurred with the current update packages, we will close this bug. 
Please re-open if the problem happens again"

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.