Bug 465842 - dapltest fails with open_hca: ERR bind (-1) Operation not permitted
dapltest fails with open_hca: ERR bind (-1) Operation not permitted
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dapl (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Doug Ledford
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 13:29 EDT by Mehdi Bozzo-Rey
Modified: 2008-10-09 10:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 10:06:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mehdi Bozzo-Rey 2008-10-06 13:29:50 EDT
Description of problem:


Version-Release number of selected component (if applicable): RHEL 5.2


How reproducible:
always

Steps to Reproduce:
1. run dapltest
  
Actual results: with debug enabled and default /etc/ofed/dat.conf put under /etc


[mbozzore@compute-00-02 dapl-1.2.5]$ dapltest
DAT Registry: Started (dat_init)
DAT Registry: static registry file </etc/dat.conf>

DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: token
 type  string
 value <OpenIB-cma>


DAT Registry: token
 type  string
 value <u1.2>


DAT Registry: token
 type  string
 value <nonthreadsafe>


DAT Registry: token
 type  string
 value <default>


DAT Registry: token
 type  string
 value <libdaplcma.so.1>


DAT Registry: token
 type  string
 value <dapl.1.2>


DAT Registry: token
 type  string
 value <ib0 0>


DAT Registry: token
 type  string
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: entry
 ia_name OpenIB-cma
 api_version
     type 0x0
     major.minor 1.2
 is_thread_safe 0
 is_default 1
 lib_path libdaplcma.so.1
 provider_version
     id dapl
     major.minor 1.2
 ia_params ib0 0

DAT Registry: loading provider for OpenIB-cma

DAT Registry: token
 type  string
 value <OpenIB-cma-1>


DAT Registry: token
 type  string
 value <u1.2>


DAT Registry: token
 type  string
 value <nonthreadsafe>


DAT Registry: token
 type  string
 value <default>


DAT Registry: token
 type  string
 value <libdaplcma.so.1>


DAT Registry: token
 type  string
 value <dapl.1.2>


DAT Registry: token
 type  string
 value <ib1 0>


DAT Registry: token
 type  string
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: entry
 ia_name OpenIB-cma-1
 api_version
     type 0x0
     major.minor 1.2
 is_thread_safe 0
 is_default 1
 lib_path libdaplcma.so.1
 provider_version
     id dapl
     major.minor 1.2
 ia_params ib1 0

DAT Registry: loading provider for OpenIB-cma-1

DAT Registry: token
 type  string
 value <OpenIB-cma-2>


DAT Registry: token
 type  string
 value <u1.2>


DAT Registry: token
 type  string
 value <nonthreadsafe>


DAT Registry: token
 type  string
 value <default>


DAT Registry: token
 type  string
 value <libdaplcma.so.1>


DAT Registry: token
 type  string
 value <dapl.1.2>


DAT Registry: token
 type  string
 value <ib2 0>


DAT Registry: token
 type  string
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: entry
 ia_name OpenIB-cma-2
 api_version
     type 0x0
     major.minor 1.2
 is_thread_safe 0
 is_default 1
 lib_path libdaplcma.so.1
 provider_version
     id dapl
     major.minor 1.2
 ia_params ib2 0

DAT Registry: loading provider for OpenIB-cma-2

DAT Registry: token
 type  string
 value <OpenIB-cma-3>


DAT Registry: token
 type  string
 value <u1.2>


DAT Registry: token
 type  string
 value <nonthreadsafe>


DAT Registry: token
 type  string
 value <default>


DAT Registry: token
 type  string
 value <libdaplcma.so.1>


DAT Registry: token
 type  string
 value <dapl.1.2>


DAT Registry: token
 type  string
 value <ib3 0>


DAT Registry: token
 type  string
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: entry
 ia_name OpenIB-cma-3
 api_version
     type 0x0
     major.minor 1.2
 is_thread_safe 0
 is_default 1
 lib_path libdaplcma.so.1
 provider_version
     id dapl
     major.minor 1.2
 ia_params ib3 0

DAT Registry: loading provider for OpenIB-cma-3

DAT Registry: token
 type  string
 value <OpenIB-bond>


DAT Registry: token
 type  string
 value <u1.2>


DAT Registry: token
 type  string
 value <nonthreadsafe>


DAT Registry: token
 type  string
 value <default>


DAT Registry: token
 type  string
 value <libdaplcma.so.1>


DAT Registry: token
 type  string
 value <dapl.1.2>


DAT Registry: token
 type  string
 value <bond0 0>


DAT Registry: token
 type  string
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: entry
 ia_name OpenIB-bond
 api_version
     type 0x0
     major.minor 1.2
 is_thread_safe 0
 is_default 1
 lib_path libdaplcma.so.1
 provider_version
     id dapl
     major.minor 1.2
 ia_params bond0 0

DAT Registry: loading provider for OpenIB-bond

DAT Registry: token
 type  string
 value <ofa-v2-ib0>


DAT Registry: token
 type  string
 value <u2.0>


DAT Registry: token
 type  string
 value <nonthreadsafe>


DAT Registry: token
 type  string
 value <default>


DAT Registry: token
 type  string
 value <libdaplofa.so.2>


DAT Registry: token
 type  string
 value <dapl.2.0>


DAT Registry: token
 type  string
 value <ib0 0>


DAT Registry: token
 type  string
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: entry
 ia_name ofa-v2-ib0
 api_version
     type 0x0
     major.minor 2.0
 is_thread_safe 0
 is_default 1
 lib_path libdaplofa.so.2
 provider_version
     id dapl
     major.minor 2.0
 ia_params ib0 0

DAT Registry: loading provider for ofa-v2-ib0

DAT Registry: token
 type  string
 value <ofa-v2-ib1>


DAT Registry: token
 type  string
 value <u2.0>


DAT Registry: token
 type  string
 value <nonthreadsafe>


DAT Registry: token
 type  string
 value <default>


DAT Registry: token
 type  string
 value <libdaplofa.so.2>


DAT Registry: token
 type  string
 value <dapl.2.0>


DAT Registry: token
 type  string
 value <ib1 0>


DAT Registry: token
 type  string
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: entry
 ia_name ofa-v2-ib1
 api_version
     type 0x0
     major.minor 2.0
 is_thread_safe 0
 is_default 1
 lib_path libdaplofa.so.2
 provider_version
     id dapl
     major.minor 2.0
 ia_params ib1 0

DAT Registry: loading provider for ofa-v2-ib1

DAT Registry: token
 type  string
 value <ofa-v2-ib2>


DAT Registry: token
 type  string
 value <u2.0>


DAT Registry: token
 type  string
 value <nonthreadsafe>


DAT Registry: token
 type  string
 value <default>


DAT Registry: token
 type  string
 value <libdaplofa.so.2>


DAT Registry: token
 type  string
 value <dapl.2.0>


DAT Registry: token
 type  string
 value <ib2 0>


DAT Registry: token
 type  string
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: entry
 ia_name ofa-v2-ib2
 api_version
     type 0x0
     major.minor 2.0
 is_thread_safe 0
 is_default 1
 lib_path libdaplofa.so.2
 provider_version
     id dapl
     major.minor 2.0
 ia_params ib2 0

DAT Registry: loading provider for ofa-v2-ib2

DAT Registry: token
 type  string
 value <ofa-v2-ib3>


DAT Registry: token
 type  string
 value <u2.0>


DAT Registry: token
 type  string
 value <nonthreadsafe>


DAT Registry: token
 type  string
 value <default>


DAT Registry: token
 type  string
 value <libdaplofa.so.2>


DAT Registry: token
 type  string
 value <dapl.2.0>


DAT Registry: token
 type  string
 value <ib3 0>


DAT Registry: token
 type  string
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: entry
 ia_name ofa-v2-ib3
 api_version
     type 0x0
     major.minor 2.0
 is_thread_safe 0
 is_default 1
 lib_path libdaplofa.so.2
 provider_version
     id dapl
     major.minor 2.0
 ia_params ib3 0

DAT Registry: loading provider for ofa-v2-ib3

DAT Registry: token
 type  string
 value <ofa-v2-bond>


DAT Registry: token
 type  string
 value <u2.0>


DAT Registry: token
 type  string
 value <nonthreadsafe>


DAT Registry: token
 type  string
 value <default>


DAT Registry: token
 type  string
 value <libdaplofa.so.2>


DAT Registry: token
 type  string
 value <dapl.2.0>


DAT Registry: token
 type  string
 value <bond0 0>


DAT Registry: token
 type  string
 value <>


DAT Registry: token
 type  eor
 value <>


DAT Registry: entry
 ia_name ofa-v2-bond
 api_version
     type 0x0
     major.minor 2.0
 is_thread_safe 0
 is_default 1
 lib_path libdaplofa.so.2
 provider_version
     id dapl
     major.minor 2.0
 ia_params bond0 0

DAT Registry: loading provider for ofa-v2-bond

DAT Registry: token
 type  eof
 value <>

DAT Registry: dat_ia_openv (ofa-v2-ib0,2:0,0) called
DAT Registry: IA ofa-v2-ib0, trying to load library libdaplofa.so.2
DAPL: NOT Setting Loopback
 dapl_ib_init:
DAT Registry: dat_registry_add_provider (ofa-v2-ib0,2:0,0)
dapl_ia_open (ofa-v2-ib0, 8, 0x1482e690, 0x1482e660)
 open_hca: ib0 - 0x14832a00
 open_hca: RDMA channel created(0x148357c0,8)
 ib_thread_init(7814)
 ib_thread_init: waiting for ib_thread
 ib_thread(7814,0x4292d940): ENTER: pipe 4 ucma 8
 ib_thread_init(7814) exit
 getipaddr: family 2 port 0 addr 10.11.0.4
 open_hca: ERR bind (-1) Operation not permitted
dapls_ib_open_hca failed 120000
dapl_ia_open () returns 0x120000
DT_cs_Server: Could not open ofa-v2-ib0 (DAT_INVALID_ADDRESS )
DT_cs_Server (ofa-v2-ib0):  Exiting.
DAPL: ENTER (dapl_fini)
 dapl_ib_release:
 ib_thread_destroy(7814)
 ib_thread_destroy: waiting for ib_thread
 ib_thread(7814) poll_event:  async=0x1 pipe=0x1 cm=0x0 cq=0x0
 ib_thread(7814) EXIT
 ib_thread_destroy(7814) exit
DAPL: Exit (dapl_fini)
DAT Registry: Stopped (dat_fini)
[mbozzore@compute-00-02 dapl-1.2.5]$



Expected results:
something like : 
[root@dr08 ~]# dapltest
Dapltest: Service Point Ready - OpenIB-cma


Additional info:
Comment 1 Mehdi Bozzo-Rey 2008-10-06 22:48:13 EDT
caused by routing problem on one node; can be closed (notabug)

Note You need to log in before you can comment on or make changes to this bug.