Bug 465845 - Soft lockup vfs_quota_sync+0x8b/0x15a
Soft lockup vfs_quota_sync+0x8b/0x15a
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 13:33 EDT by Matthew Davis
Modified: 2009-07-16 21:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 21:47:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
corrupt quota db (79.00 KB, application/octet-stream)
2008-10-06 13:33 EDT, Matthew Davis
no flags Details

  None (edit)
Description Matthew Davis 2008-10-06 13:33:13 EDT
Created attachment 319577 [details]
corrupt quota db

Description of problem:

One of my boxes had this traceback in the syslog:

Oct  2 02:15:14 vertigo kernel: BUG: soft lockup - CPU#1 stuck for 10s! [repquota:3592]
Oct  2 02:15:14 vertigo kernel: CPU 1:
Oct  2 02:15:14 vertigo kernel: Modules linked in: ipt_owner xt_conntrack iptable_mangle ip_conntrack_ftp ipt_REJECT ipt_LOG xt_limit xt_multiport xt_state i
p_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables autofs4 ipmi_devintf ipmi_si ipmi_msghandler nfs lockd fscache nfs_acl sunrpc ipv6 xfrm_nal
go crypto_api dm_mirror dm_multipath dm_mod video sbs backlight i2c_ec i2c_core button battery asus_acpi acpi_memhotplug ac parport_pc lp parport sg ide_cd c
drom shpchp bnx2 i5000_edac edac_mc serio_raw pcspkr ata_piix libata mptsas mptscsih mptbase scsi_transport_sas sd_mod scsi_mod ext3 jbd uhci_hcd ohci_hcd eh
ci_hcd
Oct  2 02:15:14 vertigo kernel: Pid: 3592, comm: repquota Not tainted 2.6.18-92.1.10.el5 #1
Oct  2 02:15:14 vertigo kernel: RIP: 0010:[<ffffffff80051170>]  [<ffffffff80051170>] vfs_quota_sync+0x8b/0x15a
Oct  2 02:15:14 vertigo kernel: RSP: 0018:ffff810037ad5e38  EFLAGS: 00000202
Oct  2 02:15:14 vertigo kernel: RAX: 0000000000000033 RBX: ffff810024be3ac0 RCX: ffff810024be3af0
Oct  2 02:15:14 vertigo kernel: RDX: 0000000000000202 RSI: 0000000000000002 RDI: ffffffff802fc504
Oct  2 02:15:14 vertigo kernel: RBP: 0000000000800001 R08: 0000000000000001 R09: 000000000040ac38
Oct  2 02:15:14 vertigo kernel: R10: 0000000000000000 R11: 0000000000800001 R12: ffff810024be3ac0
Oct  2 02:15:14 vertigo kernel: R13: 0000000000800001 R14: ffff810024be3ac0 R15: 0000000000800001
Oct  2 02:15:14 vertigo kernel: FS:  00002abc914e4250(0000) GS:ffff810104386840(0000) knlGS:0000000000000000
Oct  2 02:15:14 vertigo kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Oct  2 02:15:14 vertigo kernel: CR2: 00002abc914e5000 CR3: 00000000a4ecb000 CR4: 00000000000006e0
Oct  2 02:15:14 vertigo kernel:
Oct  2 02:15:14 vertigo kernel: Call Trace:
Oct  2 02:15:14 vertigo kernel:  [<ffffffff8005119e>] vfs_quota_sync+0xb9/0x15a
Oct  2 02:15:14 vertigo kernel:  [<ffffffff800fa41a>] quota_sync_sb+0x17/0xf0
Oct  2 02:15:14 vertigo kernel:  [<ffffffff800faad2>] sys_quotactl+0x4c8/0x5fc
Oct  2 02:15:14 vertigo kernel:  [<ffffffff800b42ab>] audit_syscall_entry+0x16e/0x1a1
Oct  2 02:15:14 vertigo kernel:  [<ffffffff8005d28d>] tracesys+0xd5/0xe0


Version-Release number of selected component (if applicable):

Linux vertigo.pilotservers.com 2.6.18-92.1.13.el5 #1 SMP Thu Sep 4 03:51:21 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
quota-3.13-1.2.3.2.el5

How reproducible:

Not very.


Additional info:

Rebuilt the quota db and problem went away.  Attaching corrupt quota db.  Issued commands referenced at this url - http://forum.ensim.com/showthread.php?p=31084

quotaoff -av
mv /home/aquota.* /root/
touch /home/aquota.user
touch /home/aquota.group
quotacheck -ugiav
quotaon -av
Comment 1 RHEL Product and Program Management 2009-02-16 10:39:30 EST
Updating PM score.
Comment 2 Han Pingtian 2009-06-26 00:19:10 EDT
I can not reproduce this bug on the -155 kernel.

I have run this script on dell-pem610-01.rhts.bos.redhat.com, nothing wrong:
for ((i=0;i<100;i++));do quotaoff -av;rm -rf /home/aquota.*;touch /home/aquota.{group,user};quotacheck -ugiav;quotaon -av;done
Comment 3 Matthew Davis 2009-06-26 17:41:09 EDT
No useful data in the quotadb (attached file)?
Comment 4 Han Pingtian 2009-06-28 21:52:56 EDT
(In reply to comment #3)
> No useful data in the quotadb (attached file)?  

Do you mean we should use the attached file to reproduce this bug?
I didn't use it when trying to reproduce the bug.
Could you tell me how to use the attached file?
Comment 5 Matthew Davis 2009-06-30 13:43:30 EDT
I'm not sure, maybe placing the file on the fs and running 'repquota' ?  Its not a high priority for me, and was not able to reproduce it after the fact.  So if you cannot reproduce it, we can close it.
Comment 6 Han Pingtian 2009-06-30 23:56:32 EDT
(In reply to comment #5)
> I'm not sure, maybe placing the file on the fs and running 'repquota' ?  Its
> not a high priority for me, and was not able to reproduce it after the fact. 
> So if you cannot reproduce it, we can close it.  

I place the file on /home, named aquota.user, and run this command:
for((i=0;i<100;i++));do repquota -a -n;sleep 2;done

But cannot reproduce this bug.
Comment 7 Matthew Davis 2009-07-01 23:46:26 EDT
Ok, no need to keep it open then.  Its here in case someone else hits it.  Thanks for looking.
Comment 9 Linda Wang 2009-07-16 21:47:14 EDT
per comment#7, closing as WORKSFORME. If someone run into
this issue again, please feel free to reopen it.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.