Bug 465847 - NetworkManager does not respect NM_CONTROLLED=no
NetworkManager does not respect NM_CONTROLLED=no
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 13:33 EDT by Gilboa Davara
Modified: 2009-02-17 07:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 499583 (view as bug list)
Environment:
Last Closed: 2009-02-17 07:00:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Network configuration. (ifcfg-eth?, ifcfg-vbr?) (427 bytes, application/octet-stream)
2008-10-06 13:33 EDT, Gilboa Davara
no flags Details
Network configuration. (ifcfg-eth?, ifcfg-vbr?) [Fixed tar] (604 bytes, application/x-gzip)
2008-10-06 13:42 EDT, Gilboa Davara
no flags Details
lshal (NM disabled, for now) (142.26 KB, text/plain)
2008-10-16 07:05 EDT, Gilboa Davara
no flags Details

  None (edit)
Description Gilboa Davara 2008-10-06 13:33:42 EDT
Created attachment 319578 [details]
Network configuration. (ifcfg-eth?, ifcfg-vbr?)

Description of problem:
I'm setting up a hybrid bridged / wired / wireless network on my laptop.
I want NM to control two devices - br0 (bridged to eth0) and wlan0 - nothing else.
However, even-though ifcfg-eth[0/1] and ifcfg-vbr1 have NM_CONTROLLED=no, 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
$ grep NM_CONTROLLED= /etc/sysconfig/network-scripts/ifcfg-*
/etc/sysconfig/network-scripts/ifcfg-eth0:NM_CONTROLLED=no
/etc/sysconfig/network-scripts/ifcfg-eth1:NM_CONTROLLED=no
/etc/sysconfig/network-scripts/ifcfg-vbr0:NM_CONTROLLED=yes
/etc/sysconfig/network-scripts/ifcfg-vbr1:NM_CONTROLLED=no

$ grep BRIDGE= /etc/sysconfig/network-scripts/ifcfg-*
/etc/sysconfig/network-scripts/ifcfg-eth0:BRIDGE=br0
/etc/sysconfig/network-scripts/ifcfg-eth1:BRIDGE=br1

$ /etc/init.d/network start
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:                                [  OK  ]
Bringing up interface eth1:                                [  OK  ]
Bringing up interface vbr0:                                        
Determining IP information for br0... done.                [  OK  ]
Bringing up interface vbr1:                                [  OK  ]

$ ifconfig | egrep -e 'br|eth' -A2
br0       Link encap:Ethernet  HWaddr 00:1C:25:7E:BA:29
          inet addr:192.168.2.6  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::21c:25ff:fe7e:ba29/64 Scope:Link
--
br1       Link encap:Ethernet  HWaddr 00:E0:98:33:72:51
          inet6 addr: fe80::2e0:98ff:fe33:7251/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
--
eth0      Link encap:Ethernet  HWaddr 00:1C:25:7E:BA:29
          inet6 addr: fe80::21c:25ff:fe7e:ba29/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
--
eth1      Link encap:Ethernet  HWaddr 00:E0:98:33:72:51
          inet6 addr: fe80::2e0:98ff:fe33:7251/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1

$ /etc/init.d/NetworkManager start
Setting network parameters...                              [  OK  ]
Starting NetworkManager daemon:                            [  OK  ]

$ ifconfig | egrep -e 'br|eth' -A2
br0       Link encap:Ethernet  HWaddr 00:1C:25:7E:BA:29
          inet addr:192.168.2.6  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::21c:25ff:fe7e:ba29/64 Scope:Link
--
br1       Link encap:Ethernet  HWaddr 00:E0:98:33:72:51
          inet6 addr: fe80::2e0:98ff:fe33:7251/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
--
eth0      Link encap:Ethernet  HWaddr 00:1C:25:7E:BA:29
          inet addr:192.168.2.6  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::21c:25ff:fe7e:ba29/64 Scope:Link
--
eth1      Link encap:Ethernet  HWaddr 00:E0:98:33:72:51
          inet addr:172.18.130.95  Bcast:172.18.130.255  Mask:255.255.255.0
          inet6 addr: fe80::2e0:98ff:fe33:7251/64 Scope:Link

=====
Both eth0 and eth1 should not get an IP address... far worse, shouldn't NM automatically ignore bridged network devices?
=====

- Gilboa
Comment 1 Gilboa Davara 2008-10-06 13:35:07 EDT
Uggh... Hit send by mistake.

Versions:
$ rpm -qa | grep NetworkManager
NetworkManager-gnome-0.7.0-0.11.svn4022.fc9.x86_64
NetworkManager-glib-0.7.0-0.11.svn4022.fc9.x86_64
NetworkManager-0.7.0-0.11.svn4022.fc9.x86_64

Easily reproducible.
Comment 2 Gilboa Davara 2008-10-06 13:42:04 EDT
Created attachment 319579 [details]
Network configuration. (ifcfg-eth?, ifcfg-vbr?) [Fixed tar]
Comment 3 Gilboa Davara 2008-10-06 13:44:12 EDT
$ /usr/sbin/nm-system-settings --debug --plugins=ifcfg-fedora
** Message: Loaded plugin ifcfg-fedora: (c) 2007 - 2008 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
** Message:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
** Message:    ifcfg-fedora:     error: Ignoring loopback device config.
** Message:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-vbr1 ...
** Message:    ifcfg-fedora:     error: Unknown connection type 'Bridge'
** Message:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-eth1 ...
** Message:    ifcfg-fedora:     read connection 'System eth1'
** Message:    ifcfg-fedora: Ignoring connection 'System eth1' and its device because NM_CONTROLLED was false.
** Message:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-vbr0 ...
** Message:    ifcfg-fedora:     error: Unknown connection type 'Bridge'
** Message:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ...
^C

(Killed because it hanged)
Comment 4 Dan Williams 2008-10-15 12:54:59 EDT
Can you attach the output of 'lshal' as well?  I'd like to see if/how HAL detects the bridges...
Comment 5 Gilboa Davara 2008-10-16 07:05:32 EDT
Created attachment 320543 [details]
lshal (NM disabled, for now)
Comment 6 Felix Schwarz 2008-12-28 08:48:26 EST
For me this worked on F10. Reporter, is this still a problem for you?
Comment 7 Gilboa Davara 2009-02-16 06:50:10 EST
I just enabled NM (under F10), and it does honor NM_CONTROLLED=no.
Bug seems to be fixed. Please close.
Comment 8 Dan Williams 2009-02-17 07:00:38 EST
Ok, thanks!

Note You need to log in before you can comment on or make changes to this bug.