Bug 465865 - NM_CONTROLLED=no did not disable NM control over eth0
NM_CONTROLLED=no did not disable NM control over eth0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
: Desktop, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 15:55 EDT by Suzanne Hillman
Modified: 2008-10-13 23:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-13 23:07:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifcfg-etho file (152 bytes, text/plain)
2008-10-07 15:58 EDT, Suzanne Hillman
no flags Details

  None (edit)
Description Suzanne Hillman 2008-10-06 15:55:44 EDT
Description of problem:
NM_CONTROLLED=no did not disable NM control over eth0

Version-Release number of selected component (if applicable):
NM-0.7.0-0.11.svn4133.el5

How reproducible:
always, at least on this machine

Steps to Reproduce:
1. Edit /etc/sysconfig/network-scripts/ifcfg-eth0
2. Add "NM_CONTROLLED=no" to the file.
3. Restart NetworkManager
  
Actual results:
Brought eth0 up.

Expected results:
Should not bring eth0 up even if there is a connection avaialble.

Additional info:
Comment 1 Dan Williams 2008-10-06 16:57:47 EDT
can you attach the ifcfg file from this machine?

Also, can you 'killall -TERM NetworkManager' and 'killall -TERM nm-system-settings' then do the following (as root) and add the output to this bug?

/usr/sbin/nm-system-settings --debug --plugins=ifcfg-fedora
Comment 2 Suzanne Hillman 2008-10-07 15:58:11 EDT
Created attachment 319691 [details]
ifcfg-etho file
Comment 3 Suzanne Hillman 2008-10-07 16:00:32 EDT
[root@localhost ~]# /usr/sbin/nm-system-settings --debug --plugins=ifcfg-fedora
** Message: Loaded plugin ifcfg-fedora: (c) 2007 - 2008 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
** Message:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ...
** Message:    ifcfg-fedora:     read connection 'System eth0'
** Message:    ifcfg-fedora: Ignoring connection 'System eth0' and its device because NM_CONTROLLED was false.
** Message:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-wmaster0 ...
** Message:    ifcfg-fedora:     read connection 'System wmaster0'
** Message:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-lo ... 
** Message:    ifcfg-fedora:     error: Ignoring loopback device config.

----

with it commented out:

[root@localhost ~]# /usr/sbin/nm-system-settings --debug --plugins=ifcfg-fedora
** Message: Loaded plugin ifcfg-fedora: (c) 2007 - 2008 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
** Message:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ...
** Message:    ifcfg-fedora:     read connection 'System eth0'
** Message:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-wmaster0 ...
** Message:    ifcfg-fedora:     read connection 'System wmaster0'
** Message:    ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-lo ... 
** Message:    ifcfg-fedora:     error: Ignoring loopback device config.

---

also, there was no nm-system-settings to be killed by the killall.
Comment 4 Suzanne Hillman 2008-10-07 16:05:24 EDT
This _may_ be fixed in the newer build (20081006.0); I'm not willing to reinstall to find out until I'm sure you have the info you need from this machine.
Comment 5 Suzanne Hillman 2008-10-09 15:53:03 EDT
This is in fact fixed in the 20081006.0 build. Verified state (not sure what other state might make sense, so).

Note You need to log in before you can comment on or make changes to this bug.