Bug 465895 - Audio lags when using A2DP (stereo bluetooth)
Audio lags when using A2DP (stereo bluetooth)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 20:10 EDT by Bastien Nocera
Modified: 2009-04-10 10:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 10:09:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2008-10-06 20:10:43 EDT
When watching a film using Totem, the audio lags behind the video by about half a second.
Comment 1 Lennart Poettering 2008-10-07 13:52:33 EDT
Timing is borked in the BT code. I am no sure if we can fix this ever since A2DP does not provide any useful timing information.
Comment 2 Bug Zapper 2008-11-25 22:37:07 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Lennart Poettering 2009-04-10 10:09:07 EDT
Should be fixed in pulseaudio-0.9.15-9.test8.fc11

This is a bit hackish since BT doesn't really hand us any timing information. It works with a staticly defined latency, which worked quite well for my headsets and headphones.

Note You need to log in before you can comment on or make changes to this bug.