Bug 465912 - vio_register_device_node: failed to register device 4003
vio_register_device_node: failed to register device 4003
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
ppc64 Linux
low Severity low
: rc
: ---
Assigned To: Ameet Paranjape
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 01:12 EDT by CAI Qian
Modified: 2013-03-07 19:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 20:57:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (11.03 KB, text/plain)
2008-10-07 01:12 EDT, CAI Qian
no flags Details

  None (edit)
Description CAI Qian 2008-10-07 01:12:21 EDT
Created attachment 319615 [details]
dmesg

Description of problem:
The following failure showed during a PPC64 machine boot,

NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 2, 262144 bytes)
TCP established hash table entries: 131072 (order: 5, 2097152 bytes)
TCP bind hash table entries: 65536 (order: 4, 1048576 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
vio_bus_init: processing c0000000f7ffba28
vio_bus_init: processing c0000000f7ffbbe0
vio_bus_init: processing c0000000f7ffbdb8
vio_bus_init: processing c0000000f7ffbef0
vio_bus_init: processing c0000000f7ffc048
vio_bus_init: processing c0000000f7ffc1a0
vio_bus_init: processing c0000000f7ffc438
kobject_add failed for 4003 with -EEXIST, don't try to register things with the same name in the same directory.
Call Trace:
[C00000000FF1FBA0] [C000000000010378] .show_stack+0x68/0x1b0 (unreliable)
[C00000000FF1FC40] [C0000000001B6F90] .kobject_add+0x1a4/0x1fc
[C00000000FF1FCE0] [C0000000002819A4] .device_add+0x88/0x3b0
[C00000000FF1FD90] [C000000000022020] .vio_register_device_node+0x1dc/0x238
[C00000000FF1FE40] [C00000000046A110] .vio_bus_init+0x98/0xc4
[C00000000FF1FEC0] [C000000000460518] .init+0x250/0x388
[C00000000FF1FF90] [C000000000026FFC] .kernel_thread+0x4c/0x68
vio_register_device_node: failed to register device 4003
IBM eBus Device Driver
scan-log-dump not implemented on this system
RTAS daemon started
RTAS: event: 5333, Type: Dump Notification Event, Severity: 2
audit: initializing netlink socket (disabled)
audit(1223349908.165:1): initialized
Total HugeTLB memory allocated, 0


Version-Release number of selected component (if applicable):
kernel-2.6.18-92.el5
kernel-2.6.18-118.el5

How reproducible:
always

Steps to Reproduce:
1. boot ibm-js21-01.lab.bos.redhat.com
Comment 4 Linda Wang 2009-02-16 07:12:29 EST
Cai, does this still happened on
Comment 5 RHEL Product and Program Management 2009-02-16 10:43:58 EST
Updating PM score.
Comment 6 CAI Qian 2009-02-16 20:45:55 EST
Yes, I have still seen it with -120.el5 kernel,
http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=4818818
I am trying the -128.el5 now, and will update once done.
Comment 8 CAI Qian 2009-05-01 12:33:29 EDT
The machine is available again. I'll reserve it, and test it as soon as possible.
Comment 9 CAI Qian 2009-05-04 03:55:03 EDT
Someone put an access key on this machine. I'll need to ask system admins to access it.
Comment 11 CAI Qian 2009-05-05 20:57:06 EDT
I'll close this one out, since the machine is still unavailable, and I have not seen it on any other machine so far.

Note You need to log in before you can comment on or make changes to this bug.