Bug 465930 - activation of satellite after external db migration from 9i to 10g failed
activation of satellite after external db migration from 9i to 10g failed
Status: CLOSED DUPLICATE of bug 465312
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
520
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 03:42 EDT by Thorsten Scherf
Modified: 2008-10-07 09:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 09:11:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2008-10-07 03:42:10 EDT
Description of problem:

I have a freshly installed 10g oracle sid where I imported a 9i dump. after running install.pl I got the following error after importing of the satellite-cert:

ERROR: RHN Entitlement Certificate failed to validate: 
Exception reported from station12.example.com
Time: Tue Oct  7 09:34:08 2008
Exception type server.rhnSQL.sql_base.SQLStatementPrepareError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/satellite_tools/rhn_satellite_activate.py", line 202, in activateSatellite_local
    satCerts.storeRhnCert(cert, check_generation=1, check_version=not(options.ignore_version_mismatch))
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 235, in storeRhnCert
    row = retrieve_db_cert()
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 318, in retrieve_db_certERROR: RHN Entitlement Certificate failed to validate: 
Exception reported from station12.example.com
Time: Tue Oct  7 09:34:08 2008
Exception type server.rhnSQL.sql_base.SQLStatementPrepareError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/satellite_tools/rhn_satellite_activate.py", line 202, in activateSatellite_local
    satCerts.storeRhnCert(cert, check_generation=1, check_version=not(options.ignore_version_mismatch))
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 235, in storeRhnCert
    row = retrieve_db_cert()
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 318, in retrieve_db_cert
    h.execute(label=label)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 100, in execute
    return apply(self._execute_wrapper, (self._execute, ) + p, kw)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 148, in _execute_wrapper
    raise apply(sql_base.SQLStatementPrepareError, args)
SQLStatementPrepareError: ('ORA-00942: table or view does not exist\n', 942, "SELECT nvl(version, 0) version, version orig_version, cert, TO_CHAR(issued, 'YYYY-MM-DD HH24:MI:SS') issued, TO_CHAR(expires, 'YYYY-MM-DD HH24:MI:SS') expires FROM rhnSatelliteCert WHERE label = :label ORDER BY version DESC NULLS LAST")

    h.execute(label=label)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 100, in execute
    return apply(self._execute_wrapper, (self._execute, ) + p, kw)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 148, in _execute_wrapper
    raise apply(sql_base.SQLStatementPrepareError, args)
SQLStatementPrepareError: ('ORA-00942: table or view does not exist\n', 942, "SELECT nvl(version, 0) version, version orig_version, cert, TO_CHAR(issued, 'YYYY-MM-DD HH24:MI:SS') issued, TO_CHAR(expires, 'YYYY-MM-DD HH24:MI:SS') expires FROM rhnSatelliteCert WHERE label = :label ORDER BY version DESC NULLS LAST")


Version-Release number of selected component (if applicable):
Satellite-5.2.0-RHEL5-re20081002.2-i386.iso

How reproducible:
run install.pl

Steps to Reproduce:
1.import 9i dump into 10g external db
2.run install.pl
3.import sat 5.2 cert
  
Actual results:
see error above

Expected results:
activation of satellite works

Additional info:
Comment 1 Thorsten Scherf 2008-10-07 09:02:11 EDT
this is a DUPLICATE to BZ #465312, after creating other_tbs tablespace the import worked without error and activation of satellite was also possible.
Comment 2 Jan Pazdziora 2008-10-07 09:11:16 EDT
(In reply to comment #1)
> this is a DUPLICATE to BZ #465312, after creating other_tbs tablespace the
> import worked without error and activation of satellite was also possible.

Closing as such.

*** This bug has been marked as a duplicate of bug 465312 ***

Note You need to log in before you can comment on or make changes to this bug.