Bug 465975 - system-config-printer crashes when browsing for samba printers
system-config-printer crashes when browsing for samba printers
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 10:43 EDT by Pavel Rosenboim
Modified: 2008-10-20 11:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.0.8-7.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 11:08:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of the commanf (9.35 KB, text/plain)
2008-10-16 12:34 EDT, Pavel Rosenboim
no flags Details

  None (edit)
Description Pavel Rosenboim 2008-10-07 10:43:53 EDT
Description of problem:
When trying to browse samba printers, s-c-p segfaults. If run from console nothing is printed except "Segmentation fault"

Version-Release number of selected component (if applicable):
1.0.8-2.fc10

How reproducible:
Always

Steps to Reproduce:
1. Attempt to add new printer
2. Select "Windows Printer via SAMBA" in the list
3. Click "Browse" on the right
  
Actual results:
Application crashes.
Comment 1 Tim Waugh 2008-10-07 10:57:42 EDT
What does 'rpm -q libsmbclient' say?
Comment 2 Pavel Rosenboim 2008-10-07 11:19:51 EDT
libsmbclient-3.2.4-0.22.fc10.i386
Comment 3 Tim Waugh 2008-10-08 13:02:58 EDT
Hmm, I can't reproduce this here.

Can you get the small example SMB browser application to crash when you run this from the command line?:

/usr/share/doc/system-config-printer-libs-*/pysmbc-*/test.py
Comment 4 Pavel Rosenboim 2008-10-12 07:30:55 EDT
session request to 172.30.30.83 failed (Called name not present)
Segmentation fault
Comment 5 Tim Waugh 2008-10-16 10:45:08 EDT
How about this (cut and paste into a terminal)?:

PYSMBC_DEBUG=1 python <<EOF
import sys
import smbc
c=smbc.Context (debug=3)
print >>sys.stderr, c
d=c.opendir("smb://")
print >>sys.stderr, d
print >>sys.stderr, d.getdents ()
EOF
Comment 6 Pavel Rosenboim 2008-10-16 12:34:15 EDT
Created attachment 320575 [details]
Output of the commanf

Log attached
Comment 7 Tim Waugh 2008-10-17 05:27:27 EDT
Please try system-config-printer-1.0.8-7.fc10:
  http://koji.fedoraproject.org/koji/buildinfo?buildID=66642
Comment 8 Pavel Rosenboim 2008-10-19 11:39:58 EDT
Looks fine.
Comment 9 Tim Waugh 2008-10-20 11:08:21 EDT
Great, thanks for helping to track it down.

Note You need to log in before you can comment on or make changes to this bug.