Bug 465990 - x86_64 rhel3 hvm installations are busted on rhel 5.3 amd dom0
x86_64 rhel3 hvm installations are busted on rhel 5.3 amd dom0
Status: CLOSED DUPLICATE of bug 224482
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 12:27 EDT by Gurhan Ozen
Modified: 2013-11-03 20:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 03:04:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2008-10-07 12:27:42 EDT
Description of problem:
This is a familiar problem. The installations, though they might take a while, do happen, but the guests take forever to boot and are unusuable. The trace log file will be attached to this bug report. 

Version-Release number of selected component (if applicable):
# uname -a 
Linux amd-shanghai-01.rhts.bos.redhat.com 2.6.18-117.el5xen #1 SMP Mon Sep 29 22:42:46 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
# rpm -qa | grep xen 
kernel-xen-2.6.18-117.el5
kmod-gnbd-xen-0.1.5-2.el5
xen-3.0.3-73.el5
xen-devel-3.0.3-73.el5
kmod-gfs-xen-0.1.26-1.el5
kernel-xen-devel-2.6.18-117.el5
xen-libs-3.0.3-73.el5
xen-devel-3.0.3-73.el5
xen-libs-3.0.3-73.el5
kmod-cmirror-xen-0.1.18-1.el5
kmod-gfs2-xen-1.116-1.12.el5


How reproducible:
Everytime.

Steps to Reproduce:
1. install rhel 5.3 dom0 on an amd box.
2. virt-install --name rhel3.8_x86_64_hvm_guest --cdrom /var/lib/xen/images/rhel3.8_x86_64_hvm.iso --file /var/lib/xen/images/rhel3.8_x86_64_hvm_guest.img --nonsparse --hvm --ram 1024 --file-size 10
3. 
  
Actual results:
The guest installs , it might take a long time. However it's unusably slow and keeps on printing these msgs:

Saving random seed:  hda: dma_timer_expiry: dma status == 0x24
hda: DMA interrupt recovery
hda: lost interrupt
hda: dma_timer_expiry: dma status == 0x24
hda: DMA interrupt recovery
hda: lost interrupt

Expected results:
Should boot up and work just fine.

Additional info:
I was able to reliably reproduce this on amd-shanghai-01.rhts.bos.redhat.com. You can use that machine on rhts. It did, however work just fine on an Intel box.
Comment 1 Chris Lalancette 2008-10-08 03:04:30 EDT
This is not new with 5.3, unfortunately.  This has been the case for quite a while, and there hasn't been sufficient interest (yet) in debugging/fixing it.  I'm going to close this one out as a dup of the older bug.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 224482 ***

Note You need to log in before you can comment on or make changes to this bug.