This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 466006 - mysterious fail dialog.
mysterious fail dialog.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
: 468662 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 13:37 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 09:02:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fail dialog. (38.94 KB, image/jpeg)
2008-10-07 13:37 EDT, Dave Jones
no flags Details

  None (edit)
Description Dave Jones 2008-10-07 13:37:35 EDT
Created attachment 319674 [details]
fail dialog.

the icon in my task bar showed I had updates. I tried to apply them, and got the attached dialog which isn't really helpful.  Success ?
Comment 1 Richard Hughes 2008-10-07 16:14:00 EDT
How did you initiate the update? Right click, update system? I'm not sure why we fail like that -- do you get an identical error message when doing "yum update"?
Comment 2 Dave Jones 2008-10-07 16:24:52 EDT
yeah that was just a right click & update.

yum update from the command gives a more helpful message..

--> Running transaction check
--> Processing Dependency: xmms-libs = 1:1.2.10 for package: xmms-mp3
---> Package xmms-libs.i386 1:1.2.11-1.20071117cvs.1.fc9 set to be updated
--> Finished Dependency Resolution
xmms-mp3-1.2.10-5.lvn6.x86_64 from installed has depsolving problems
  --> Missing Dependency: xmms-libs = 1:1.2.10 is needed by package xmms-mp3-1.2.10-5.lvn6.x86_64 (installed)
Error: Missing Dependency: xmms-libs = 1:1.2.10 is needed by package xmms-mp3-1.2.10-5.lvn6.x86_64 (installed)
Comment 3 Richard Hughes 2008-10-07 16:28:56 EDT
Does "pkcon update" give you a proper error? Thx.
Comment 4 Dave Jones 2008-10-07 16:39:45 EDT
yeah.

$ pkcon update
Error: dep-resolution-failed : Success - empty transaction
Comment 5 Richard Hughes 2008-10-26 12:10:14 EDT
I've fixed this upstream, thanks:

commit 9baa2f3805a956cf967e0cba5db5e1d7a1ccdf3a
Author: Richard Hughes <richard@hughsie.com>
Date:   Sun Oct 26 16:09:01 2008 +0000

    yum: emit a proper error message when we fail to depsolve and then have nothing to do. Fixes rh#466006
Comment 6 Richard Hughes 2008-10-27 06:53:57 EDT
*** Bug 468662 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.