Bug 466020 - Speakers don't work on HP laptop
Speakers don't work on HP laptop
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-07 14:33 EDT by Linuxguy123
Modified: 2010-03-09 11:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 01:47:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vnn (14.57 KB, text/plain)
2008-10-10 18:51 EDT, Linuxguy123
no flags Details
/var/log/messages (1.38 MB, text/plain)
2008-10-10 18:54 EDT, Linuxguy123
no flags Details

  None (edit)
Description Linuxguy123 2008-10-07 14:33:17 EDT
Description of problem:

Sound won't come out of the speakers on my HP hdx9494.  Nor does it come out of headphone jack #1.   But it does come out of headphone jack #2. 

Version-Release number of selected component (if applicable):

$ uname -a
Linux localhost.localdomain 2.6.26.5-28.fc8 #1 SMP Sat Sep 20 09:32:58 EDT 2008 i686 i686 i386 GNU/Linux

$ yum list *alsa*
Installed Packages
alsa-lib.i386                            1.0.16-3.fc8           installed
alsa-lib-devel.i386                      1.0.16-3.fc8           installed
alsa-utils.i386                          1.0.16-3.fc8           installed
bluez-utils-alsa.i386                    3.20-7.fc8             installed

$ yum list *oss*
Installed Packages
nss_compat_ossl.i386                     0.9.4-1.fc8            installed

$ /sbin/lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8800M GTS (rev a2)
02:06.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
02:06.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
02:06.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
02:06.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
02:06.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
10:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
20:00.0 Mass storage controller: Silicon Image, Inc. Unknown device 3531 (rev 01)
28:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller (rev 13)

$ /sbin/lsmod
Module                  Size  Used by
rfcomm                 32721  0
l2cap                  21953  9 rfcomm
autofs4                20933  2
sunrpc                154785  3
nf_conntrack_ipv4      11849  2
ipt_REJECT              6977  2
iptable_filter          6849  1
ip_tables              14033  1 iptable_filter
nf_conntrack_ipv6      16469  2
xt_state                6209  4
nf_conntrack           51221  3 nf_conntrack_ipv4,nf_conntrack_ipv6,xt_state
xt_tcpudp               6977  8
ip6t_ipv6header         6209  2
ip6t_REJECT             7617  2
ip6table_filter         6593  1
ip6_tables             15057  2 ip6t_ipv6header,ip6table_filter
x_tables               15557  7 ipt_REJECT,ip_tables,xt_state,xt_tcpudp,ip6t_ipv6header,ip6t_REJECT,ip6_tables
cpufreq_ondemand       10445  1
acpi_cpufreq           11981  1
dm_mirror              19521  0
dm_log                 12357  1 dm_mirror
dm_multipath           18505  0
dm_mod                 48521  3 dm_mirror,dm_log,dm_multipath
ipv6                  238405  16 nf_conntrack_ipv6,ip6t_REJECT
snd_hda_intel         331001  6
snd_seq_dummy           6853  0
snd_seq_oss            29633  0
snd_seq_midi_event      9921  1 snd_seq_oss
snd_seq                44913  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
arc4                    5953  2
firewire_ohci          22469  0
snd_seq_device          9933  3 snd_seq_dummy,snd_seq_oss,snd_seq
ecb                     6849  2
firewire_core          35553  1 firewire_ohci
snd_pcm_oss            37441  0
crypto_blkcipher       18373  1 ecb
nvidia               7091012  26
snd_mixer_oss          16705  2 snd_pcm_oss
sdhci                  17989  0
snd_pcm                61509  3 snd_hda_intel,snd_pcm_oss
mmc_core               41565  1 sdhci
crc_itu_t               6081  1 firewire_core
ricoh_mmc               7873  0
iwl4965               153029  0
video                  20817  5
output                  6849  1 video
iwlcore               128901  1 iwl4965
snd_timer              21065  3 snd_seq,snd_pcm
uvcvideo               50121  0
snd_page_alloc         11337  2 snd_hda_intel,snd_pcm
rfkill                 11481  2 iwlcore
snd_hwdep              10309  1 snd_hda_intel
snd                    46437  17 snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
compat_ioctl32          5313  1 uvcvideo
mac80211              175669  2 iwl4965,iwlcore
ac                      8005  0
wmi                     9961  0
videodev               31425  1 uvcvideo
battery                12869  0
hci_usb                16477  2
soundcore               9633  2 snd
sky2                   42565  0
v4l1_compat            16325  2 uvcvideo,videodev
pcspkr                  6593  0
serio_raw               8901  0
i2c_i801               11985  0
cfg80211               25417  3 iwl4965,iwlcore,mac80211
joydev                 12673  0
bluetooth              47013  7 rfcomm,l2cap,hci_usb
iTCO_wdt               13925  0
i2c_core               20949  2 nvidia,i2c_i801
iTCO_vendor_support     7109  1 iTCO_wdt
sr_mod                 17541  0
sg                     31605  0
cdrom                  33249  1 sr_mod
ata_piix               19397  0
sata_sil24             16069  0
ahci                   27337  4
libata                131937  3 ata_piix,sata_sil24,ahci
sd_mod                 26329  6
scsi_mod              123917  4 sr_mod,sg,libata,sd_mod
ext3                  110281  3
jbd                    41045  1 ext3
mbcache                10309  1 ext3
uhci_hcd               22993  0
ohci_hcd               22853  0
ehci_hcd               32845  0

Sorry for not making these shorter... I don't know exactly what you might want to see. 

How reproducible:

Every time.  I've never gotten sound out of the speakers or from headphone jack #1.  Headphone jack #2 works fine, all the time.  

Steps to Reproduce:

1. Boot the laptop.
2. Login to a KDE session.
3. Start amarok.  (Xine or Helix engine)    
  
Actual results:

Sound comes out of headphone jack #2 but not the speakers or headphone jack #1. 

Expected results:

Should get sound from all outputs ?

Additional info:

The speaker will beep on the loging screen if one inputs a wrong username, etc.  I haven't tested things in gnome. 

The sound also doesn't go very loud.   I have to put all the sliders in Kmixto maximum in order to get a good volume level. 

Thanks.
Comment 1 Chuck Ebbert 2008-10-10 03:42:18 EDT
Can you attach the following (as attachments, not in the comments box):

1. Output of the command 'lspci -vnn'

2. Contents of /proc/asound/card0/codec#0

3. Contents of /var/log/dmesg

Set the type of file to text/plain when you attach them.
Comment 2 Linuxguy123 2008-10-10 18:49:40 EDT
lspci -vnn: see attached file.

ls -al /proc/asound/card0/codec#0
-r--r--r-- 1 root root 0 2008-10-10 16:46 /proc/asound/card0/codec#0
(The file is empty)

/var/log/messages: see the attached file
Comment 3 Linuxguy123 2008-10-10 18:51:00 EDT
Created attachment 320074 [details]
lspci -vnn
Comment 4 Linuxguy123 2008-10-10 18:54:14 EDT
Created attachment 320076 [details]
/var/log/messages
Comment 5 Linuxguy123 2008-10-10 18:54:53 EDT
Let me know if you need anything more.  I'll be around on and off all weekend.
Comment 6 Linuxguy123 2008-10-15 12:12:56 EDT
I solved the problem.   I ran alsamixer wherein I saw a setting for "Surround" that was muted.   I unmuted it and then I had sound coming from my speakers.

When I then ran kmix, it had a slider for "Surround".  I don't think it was there before or, if it was, it wasn't responding to the settings.  I am sure it wasn't muted in kmix as I unmuted all the outputs when I was trying to get sound working.

I think this needs to be tested.  I think kmix might have a bug.  I am not sure how to replicate the initial conditions to get it to happen again.  It might only happen on initial installation. 

Anyway... if someone is running an hdx laptop or a laptop that uses the same chipset and you don't have sound coming from the speakers, run alsamix and unmute everything.  Before you do, check if you have a Surround slider in kmix and if it is unmuted. 

I'll leave the developers figure out if this bug report should be closed and/or reassigned to kmix. 

Thanks for listening.
Comment 7 Bug Zapper 2008-11-26 06:13:53 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Linuxguy123 2008-11-27 09:53:53 EST
I've since upgraded to F10.  I can't say if this issue still exists or not because it only happens during the initial setup of the sound system.

Someone else can decide what to do with this bug.
Comment 9 Bug Zapper 2009-01-09 01:47:56 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 10 Linuxguy123 2009-09-30 12:08:23 EDT
This issue has resurfaced in F11.  Sound worked from the speakers just fine in F10.  In F11 I have nothing despite trying to manipulate all the volume sliders.

uname -a
Linux localhost.localdomain 2.6.30.8-64.fc11.i686.PAE #1 SMP Fri Sep 25 04:56:58 EDT 2009 i686 i686 i386 GNU/Linux

Please advise if you require more information.
Comment 11 Linuxguy123 2010-03-09 11:37:09 EST
Fixed with the first 2.6.32 kernel in F12. Finally.

$ uname -a
Linux localhost.localdomain 2.6.32.9-67.fc12.i686.PAE #1 SMP Sat Feb 27 09:42:55 UTC 2010 i686 i686 i386 GNU/Linux

Note You need to log in before you can comment on or make changes to this bug.