Bug 466083 - Eclipse fails to terminate
Eclipse fails to terminate
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-08 03:34 EDT by Hasan Ceylan
Modified: 2009-02-16 11:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 11:36:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hasan Ceylan 2008-10-08 03:34:33 EDT
Description of problem:
When you quit eclipse, process fails to terminate thus not releasing the huge memory eclipse holds

Version-Release number of selected component (if applicable):

#rpm -qa | grep "java\|jdk\|eclipse" | sort

eclipse-ecj-3.4.0-24.fc10.x86_64
eclipse-jdt-3.4.0-24.fc10.x86_64
eclipse-pde-3.4.0-24.fc10.x86_64
eclipse-platform-3.4.0-24.fc10.x86_64
eclipse-rcp-3.4.0-24.fc10.x86_64
eclipse-swt-3.4.0-24.fc10.x86_64
icu4j-eclipse-3.8.1-3.fc10.x86_64
java-1.5.0-gcj-1.5.0.0-22.fc10.x86_64
java-1.5.0-sun-1.5.0.15-1jpp.x86_64
java-1.5.0-sun-alsa-1.5.0.15-1jpp.x86_64
java-1.5.0-sun-demo-1.5.0.15-1jpp.x86_64
java-1.5.0-sun-devel-1.5.0.15-1jpp.x86_64
java-1.5.0-sun-src-1.5.0.15-1jpp.x86_64
java-1.6.0-openjdk-1.6.0.0-0.21.b12.fc10.x86_64
java-1.6.0-openjdk-demo-1.6.0.0-0.21.b12.fc10.x86_64
java-1.6.0-openjdk-devel-1.6.0.0-0.21.b12.fc10.x86_64
java-1.6.0-openjdk-javadoc-1.6.0.0-0.21.b12.fc10.x86_64
java-1.6.0-openjdk-plugin-1.6.0.0-0.21.b12.fc10.x86_64
java-1.6.0-openjdk-src-1.6.0.0-0.21.b12.fc10.x86_64
java-1.6.0-sun-1.6.0.7-1jpp.x86_64
java-1.6.0-sun-alsa-1.6.0.7-1jpp.x86_64
java-1.6.0-sun-devel-1.6.0.7-1jpp.x86_64
java-1.6.0-sun-src-1.6.0.7-1jpp.x86_64
java_cup-0.10k-1.x86_64
tomcat5-jasper-eclipse-5.5.26-1.5.fc10.x86_64
tzdata-java-2008f-1.fc10.noarch


How reproducible:
Everytime
Comment 1 Andrew Overholt 2008-10-08 08:29:49 EDT
Please paste the output of the commands at:

http://fedoraproject.org/wiki/DebuggingEclipseProblems
You have a few JVMs there.  Which one are you using?
Comment 2 Bug Zapper 2008-11-25 22:39:08 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Andrew Overholt 2009-02-13 15:47:15 EST
Could this be a duplicate of this bug:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=240033

?
Comment 4 Hasan Ceylan 2009-02-14 12:53:38 EST
I have been using vanilla eclipse for some time for several reasons. 
So I can no longer comment on the issue...

Hasan
Comment 5 Andrew Overholt 2009-02-16 11:36:43 EST
If you have time, I'd love to hear what your reasons were.  Private email to me is fine.

Note You need to log in before you can comment on or make changes to this bug.