Bug 466219 - Assertion if we launch 2 corosync on different node in the same time
Assertion if we launch 2 corosync on different node in the same time
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: corosync (Show other bugs)
10
All Other
low Severity low
: ---
: ---
Assigned To: Jan Friesse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 05:00 EDT by Mathieu Virbel
Modified: 2009-06-01 04:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-01 04:36:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test suite (385 bytes, application/x-sh)
2009-06-01 04:35 EDT, Jan Friesse
no flags Details

  None (edit)
Description Mathieu Virbel 2008-10-09 05:00:30 EDT
Description of problem:
We got an assertion if we launch 2 corosync on different node in the same time :

Assertion failed: (sq->items_inuse[sq_position] == 0), function sq_item_add, file /home/tito/code/fw-trunk-ha/contrib/openais/work/openais+corosync-trunk-20080918/corosync-trunk/include/corosync/sq.h, line 170.


Version-Release number of selected component (if applicable):
corosync-trunk, rev 1667
Comment 1 Mathieu Virbel 2008-10-09 05:01:41 EDT
Actual code in include/corosync/sq.h :
168     sq_item = sq->items;
169     sq_item += sq_position * sq->size_per_item;
170     assert(sq->items_inuse[sq_position] == 0); <<<<
171     memcpy (sq_item, item, sq->size_per_item);
Comment 2 Bug Zapper 2008-11-25 22:41:34 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Steven Dake 2009-03-10 11:48:12 EDT
do you have a mechanism to reproduce this issue?
Thanks
-steve
Comment 4 Steven Dake 2009-05-12 04:51:19 EDT
Honzaf, try to reproduce this issue.  Low priority atm since likely fixed in corosync trunk.
Comment 5 Jan Friesse 2009-06-01 04:35:46 EDT
Created attachment 346064 [details]
Test suite

Attached is testing script I used to reproduce this bug. On one node, sleep was set to 0.6. After 6 hours of running, I was not able to reproduce bug.

So I'm closing bug as upstream, and in case, it will reappear, please reopen bug.

Note You need to log in before you can comment on or make changes to this bug.