Bug 466252 - no way to disable scim
no way to disable scim
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: im-chooser (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 09:19 EDT by Dan Winship
Modified: 2008-10-10 23:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 23:51:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Winship 2008-10-09 09:19:35 EDT
According to the release notes:

    Use im-chooser via System ▸ Preferences ▸ Personal ▸ Input Method
    to enable or disable Input method usage on your desktop.

However, im-chooser isn't installed by default.

And apparently it doesn't work anyway? When I start it, it shows that I have disabled IM support, and yet scim is still running. And I can toggle the checkboxes as much as I want, and scim stays running.
Comment 1 Akira TAGOH 2008-10-09 10:44:52 EDT
Which locale and which version of imsettings are you using?

First, as it's also described in http://fedoraproject.org/wiki/Docs/Beats/I18n, IM is running by default for as, bn, gu, hi, ja, kn, ko, ml, mr, ne, or, pa, si, ta, te, th, ur, vi, zh locales only. otherwise it won't work unless you change the setting.

Assuming you are on one of them as you saw SCIM. this would explains why you still see SCIM running after disabiling it:
http://bugzilla.gnome.org/show_bug.cgi?id=522885

As long as GTK+ has instances of immodule, SCIM process keeps alive.

Is it what you're saying? or did you see that on Qt/KDE? then Than is working on that IIRC.

BTW I'm respecting the summary of this bug and "im-chooser isn't installed by default" issue should be filed separately IMHO.
Comment 2 Dan Winship 2008-10-09 12:07:23 EDT
imsettings-0.104.1-3.fc10.x86_64

LANG is en_US.utf8. No LC_* variables are set. System->Administration->Locale confirms that the system locale is "English (USA)".

So something is even more wrong than I thought, since from what you're saying, SCIM shouldn't have been running in the first place in my locale.
Comment 3 Akira TAGOH 2008-10-09 20:39:58 EDT
Ok, can you attach .xsession-errors then?
Comment 4 Jens Petersen 2008-10-10 02:29:15 EDT
I added requires im-chooser to scim-1.4.7-34.fc10.
Comment 5 Dan Winship 2008-10-10 11:22:13 EDT
Hm... in that login session, my .xsession-errors started:

  imsettings information
  ==========================
  Is DBus enabled: yes
  Is imsettings enabled: yes
  Is GTK+ supported: yes
  Is Qt supported: no
  DESKTOP_SESSION: gnome
  DISABLE_IMSETTINGS: 
  IMSETTINGS_DISABLE_DESKTOP_CHECK: 
  DBUS_SESSION_BUS_ADDRESS: unix:abstract=/tmp/dbus-bTnQMscRly,guid=f47812ddfae44c0d2b56174d48ee00a3
  GTK_IM_MODULE: 
  QT_IM_MODULE: xim
  XMODIFIERS: @im=imsettings
  IMSETTINGS_MODULE: SCIM
  
  Started SCIM

but when I logged out and back in (to try it with the latest packages), I get:

  imsettings information
  ==========================
  Is DBus enabled: yes
  Is imsettings enabled: yes
  Is GTK+ supported: yes
  Is Qt supported: no
  DESKTOP_SESSION: gnome
  DISABLE_IMSETTINGS: 
  IMSETTINGS_DISABLE_DESKTOP_CHECK: 
  DBUS_SESSION_BUS_ADDRESS: unix:abstract=/tmp/dbus-Jct8g1Uv1z,guid=3e56866f27b83fb4e678ff5948ef70bb
  GTK_IM_MODULE: 
  QT_IM_MODULE: 
  XMODIFIERS: @im=imsettings
  IMSETTINGS_MODULE: none
  
  
  (imsettings-start:3672): IMSettings-WARNING **: Failed to invoke a method `StartIM':
    No XIM server is available in none
  Failed to start IM process `none'


So it seems to be working now... I don't know what was wrong before? :-/
Comment 6 Akira TAGOH 2008-10-10 23:51:28 EDT
I don't even know what happened there, but AFAICS you have changed the IM setting before or you have had .xinputrc symlink'ed to /etc/X11/xinit/xinput.d/scim.conf anyway.

Closing now. if you see this issue again, please reopen this. thanks.

Note You need to log in before you can comment on or make changes to this bug.