Bug 466405 - Search in the oVirt UI is not finding smart pools and it is not locating the successful searched object in the hierarchy
Search in the oVirt UI is not finding smart pools and it is not locating the ...
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Scott Seago
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 00:28 EDT by Susan Burgess
Modified: 2013-03-13 01:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-21 13:16:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susan Burgess 2008-10-10 00:28:16 EDT
Description of problem:
Search tool is not finding smart pools and it is not locating the successful searched object in the hierarchy

Version-Release number of selected component (if applicable):


How reproducible:
Use the Search to find an existing smart pool.

Steps to Reproduce:
1. Click Search in the oVirt Server Suite UI
2. Enter the name of a preexisting (from previous sessions) smart pool
3. 
  
Actual results:
"NO results found" displayed even for an existing smart pool

Expected results:

should find the pool and display in the Contents pane, and locate the node in the hierarchy browser tree.
----------------------------------

How reproducible:
Use the Search to find an existing pool

Steps to Reproduce:
1. Click Search in the oVirt Server Suite UI
2. Enter the name of a preexisting (from previous sessions) pool
3. 
  
Actual results:
Finds pool and displays in the Contents pane only
Expected results:
Finds pool and displays in the Contents pane and in the brwser tree.

should find the pool and display in the Contents pane, and locate the node in the hierarchy browser tree.
Comment 1 koka xiong 2008-10-12 23:43:30 EDT
No pool can be found include virtual machine.
Comment 2 Jia Dong 2009-01-21 02:09:02 EST
It also exists in version 0.96.
Comment 3 Scott Seago 2009-01-28 13:02:50 EST
Ok, so there are a couple different things reported here:

1) smart pools don't show up in the results, as they are not indexed. Smart pools are just a way of user tagging, so the smart pools themselves do not show up in the search results.

2) New content was not being indexed as it was created, as we didn't have the automatic search index updates in place. I've committed a fix that updates search results every 5 minutes, so after the next release it should take no more than 5 minutes for search results to show up.

3) Clicking on search results does not update the tree navigation, since at the moment we're not actually going to the main page for the found items -- we're just displaying the details pane for the results. If we add the ability to navigate directly from the search results to the appropriate hardware or VM pool tab for the found item we'll include the tree update as well.

Note You need to log in before you can comment on or make changes to this bug.