Bug 466435 - THE PRINTER ADDED VIA LPADMIN, IT 'S OPTION IS NOT EDITABLE ON PRINTCONF ON EL4
THE PRINTER ADDED VIA LPADMIN, IT 'S OPTION IS NOT EDITABLE ON PRINTCONF ON EL4
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: printconf (Show other bugs)
4.9
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tim Waugh
http://bugzilla.oracle.com/bugzilla/s...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 05:42 EDT by xiaowei.hu
Modified: 2008-10-10 06:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 06:24:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xiaowei.hu 2008-10-10 05:42:48 EDT
Description of problem:

This issue exists on RHEL/OEL 4 U5/U6/U7.Once clicked the "Apply" button or
"Save" button on printer GUI tool(printconf or printtool),after this action
executed that add any printer by command line with "lpadmin" which will not
be  editable on the printer GUI tool(printconf or printtool).
 Tested on EL5U1, this issue does not exist. 


Version-Release number of selected component (if applicable):

printconf-0.6.116.10

How reproducible:


1, Add two printers by command line one by one;
@ # lpadmin -p terry1 -v socket://fiyta16b.cn.oracle.com:631 -D "Terry test" -L
"FYT"
[root@Terry ~]# accept terry1
@ [root@Terry ~]# lpadmin -p terry2 -v socket://fiyta16b.cn.oracle.com:631 -D
"Terry test" -L "FYT"
[root@Terry ~]# accept terry2
[root@Terry ~]# lpstat -a
terry1 accepting requests since Jan 01 00:00
terry2 accepting requests since Jan 01 00:00

2, Run the printer GUI configuration tool:
#printconf

 Both printer terry1 and terry2 are work fine. Select any one of them, the
printer option "Edit" button is available.
 Either add a new printer via the GUI tool or change anything and click
"Apply" to quit the GUI progam.

3,Add a printer by command line;

@ [root@Terry ~]# lpadmin -p terry3 -v socket://fiyta16b.cn.oracle.com:631 -D
"Terry test" -L "FYT"
[root@Terry ~]# accept terry3
[root@Terry ~]# lpstat -a
terry1 accepting requests since Jan 01 00:00
terry2 accepting requests since Jan 01 00:00
terry3 accepting requests since Jan 01 00:00

4, Run the printer GUI configuration tool:
#printconf

 We can see the latest added printer "terry3" under "Browsed queues", select
this printer, but the "Edit" button is disabled. But this printer can work
too. It's fine to print the test page via printer "terry3".

  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2008-10-10 06:24:13 EDT
This is a design limitation of the printer configuration tool included in Red Hat Enterprise Linux 4.

The tool was re-written to avoid this design limitation for Red Hat Enterprise Linux 5.

Note You need to log in before you can comment on or make changes to this bug.