Bug 466445 - smol doesn't send profile - Error contacting Server: [Errno 14] HTTP Error 500: Internal error
smol doesn't send profile - Error contacting Server: [Errno 14] HTTP Error 50...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 06:10 EDT by Valent Turkovic
Modified: 2009-06-22 15:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 15:34:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2008-10-10 06:10:20 EDT
Description of problem:
smol doesn't send profile

I get this error:

Error contacting Server: [Errno 14] HTTP Error 500: Internal error
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 175, in <module>
    timeout=opts.timeout)
TypeError: 'int' object is not iterable


Version-Release number of selected component (if applicable):
smolt-1.1.1.1-6.fc10.noarch

How reproducible:
100%

Steps to Reproduce:
1. smoltSendProfile -a
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike McGrath 2008-10-10 11:57:04 EDT
Should be all set now.  Try it again.
Comment 2 Paul Campbell 2009-02-11 13:19:16 EST
# smoltSendProfile -c -a -d
(snip)

"f_bfree": 0}], "os": "Fedora release 10 (Cambridge)", "system_memory": "1008"}
Sending Host
Error contacting Server: [Errno 14] HTTP Error 502: Bad Gateway
Could not send - Exiting


# smoltSendProfile -c -a
Error contacting Server: [Errno 14] HTTP Error 500: Internal error
Could not send - Exiting

Different messages but same result
Comment 3 David 2009-05-26 16:05:49 EDT
I saw the same bad gateway message on two different f11 preview systems.  On one of them, I tried again 30 seconds later and it worked.
Comment 4 Mike McGrath 2009-05-26 16:30:51 EDT
I think I know what problem might be causing this.  It's been hard for me to reproduce.  I'm going to implement a change but it'll likely be after F11 ships because of the change freeze we're in.

Basically I'm going to move from the standalone app we have now to a multiprocess mod_wsgi deployment.  We'll have to see how that goes.
Comment 5 Bug Zapper 2009-06-09 05:46:08 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Valent Turkovic 2009-06-18 09:20:59 EDT
This works for me, can you also test it and close this bug if needed...
Comment 7 David 2009-06-18 12:59:37 EDT
It works for me right now too.  But it worked for me 30 seconds after it didn't work for me before, so it was an intermittent problem.
Comment 8 Mike McGrath 2009-06-22 15:34:42 EDT
Ok, I've made a few changes including a better error message.

These types of errors are almost always timeouts.  I've made it so timeouts are far less likely, but the smolt database is large enough that when we're doing backups, or if I'm re-indexing something, it's going to be much slower.  In general though, things should be much better then they were.

Note You need to log in before you can comment on or make changes to this bug.