This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 466457 - Mesa DRI rendering not working with 2.6.27-3 kernel
Mesa DRI rendering not working with 2.6.27-3 kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 07:10 EDT by Carlo Raudino
Modified: 2008-11-03 20:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-02 04:13:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlo Raudino 2008-10-10 07:10:05 EDT
Description of problem:
glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Software Rasterizer


The radeon open source driver isn't working... launching (for example) a game like nexuiz results in looooooow frame rate (software render....)

Version-Release number of selected component (if applicable):
kernel 2.6.27.0-3 fc10 from koji build system
Comment 1 Chuck Ebbert 2008-10-14 16:14:50 EDT
What kind of radeon adapter is it? Not all of them are supported...
Comment 2 Carlo Raudino 2008-10-14 16:46:08 EDT
It's well supported by DRI :) it's a radeon X1050 (so a 9550 rebranded)

with R300 chip :)

Obviously with older kernels works very very nice :)

kernel 2.6.26.6-67-fc9 output:

[carlo@karlworkstation ~]$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI R300 20060815 AGP 8x x86/MMX+/3DNow!+/SSE2 TCL
Comment 3 Carlo Raudino 2008-10-15 04:42:15 EDT
I've just given a try to kernel-2.6.27-13.fc10 from koji
because I saw this:
* Wed Oct 15 2008 Dave Airlie <airlied@redhat.com>
- radeon modesetting agp support


but nothing to do...same problem..

Maybe is not a nice idea testing fedora 10 kernels in fedora 9 environment?


Please tell me if fedora 9 + rawhide kernel is the problem, so I'll stop this bug report.

...but I remember that when I tested out fedora 10 beta 1, the video was slow...perhaps the problem is in full rawhide too...
Comment 4 Guillaume DUMOULIN 2008-11-01 04:29:11 EDT
I have the same problem with Fedora rawhide.
Fedora 9 use R300 driver.

glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Software Rasterizer

glxgears 
808 frames in 5.0 seconds = 161.589 FPS
912 frames in 5.0 seconds = 182.259 FPS


My card :
01:05.0 VGA compatible controller: ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]
Comment 5 Dave Airlie 2008-11-02 04:13:59 EST
you can't run F10 kernels in modesetting on F9.

Boot with nomodeset.

Note You need to log in before you can comment on or make changes to this bug.