Bug 466458 - unable to use non-ASCII characters in rhn_register
unable to use non-ASCII characters in rhn_register
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 07:15 EDT by Issue Tracker
Modified: 2010-10-23 01:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 17:27:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2008-10-10 07:15:30 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2008-10-10 07:15:31 EDT
State the problem

1. Provide time and date of the problem

Ticket was opened on October 6th 2008.

2. Indicate the platform(s) (architectures) the problem is being reported against.

x86_64 but it doesn't matter (well, at least I could repro on x86)

3. Provide clear and concise problem description as it is understood at the time of escalation

* Observed behaviour
Run rhn_register and type in "☺" (or anything with unicode character in it) as profile name.

An error has occurred:
exceptions.UnicodeEncodeError
See /var/log/up2date for more information

The machine then becomes visible on Red Hat Network with the specified name but the /etc/sysconfig/rhn/systemid file is empty. Running rhn_register again fails because it is not able to parse said file.

* Desired behavior 

rhn_register should either handle non-ASCII characters properly or reject them entirely.

4. State specific action requested of SEG

Modify rhn_register so it will reject non-ASCII characters before registering the system and writing an empty systemid. Alternatively you could modify rhn_register to handle non-ASCII characters properly. A third way would be to make rhn_register handle empty systemid files gracefully.

5. State whether or not a defect in the product is suspected

rhn_register which is part of rhn-setup in RHEL5 and of up2date in RHEL4 doesn't handle non-ASCII characters properly. I wasn't able to find a related Bugzilla or Issue Tracker.

 8. This is especially important for severity one and two issues. What is the impact to the customer when they experience this problem?

They just choose to use full ASCII names instead. Removing the empty systemid file, deleting the system from RHN and restarting rhn_register solves the problem. They understand "how difficult is the support of unicode in python :))" so they are just suggesting to make rhn_register more resilient.

Provide supporting info

1. State other actions already taken in working the problem:

I should have written a patch but I just spent too much time finding a nice UTF character to put in this update.

2. Attach sosreport

sosreport shows that customer is using rhn-setup-0.4.17-8.el5-noarch but I was able to reproduce the issue with up2date-4.7.1-17.el4 (although the backtrace differs).
This event sent from IssueTracker by mpoole  [Support Engineering Group]
 issue 227837

Note You need to log in before you can comment on or make changes to this bug.