Bug 466467 - pirut fails due to: Parsing primary.xml error: Extra content at the end of the document
pirut fails due to: Parsing primary.xml error: Extra content at the end of th...
Status: CLOSED DUPLICATE of bug 452538
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sebastian Skracic
Red Hat Network Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 08:48 EDT by Val
Modified: 2013-01-10 05:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-07 04:29:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Trace produced when entered root password after clicking on update available notifier box (1.89 KB, text/plain)
2008-11-12 12:00 EST, George Reeke
no flags Details
Requested ending of primary.xml.gz file (88.37 KB, text/plain)
2008-11-12 14:10 EST, George Reeke
no flags Details

  None (edit)
Description Val 2008-10-10 08:48:16 EDT
Description of problem:
Went to install yum updates and got a pirut component dump error.  I saved it to the file pirutdump.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 James Antill 2008-10-10 09:09:55 EDT
Can yopu attach that? Or at least the last few lines should make it obvious what has happened.
Comment 2 George Reeke 2008-11-12 12:00:23 EST
Created attachment 323352 [details]
Trace produced when entered root password after clicking on update available notifier box

I got this crash this morning while trying to apply a routine RedHat update
to my EL 5.2 SMP x86_64 system.  It appears to fit this existing bug report.
This process has always worked routinely until today.
The attachment was generated by the system with a request to file it at
bugzilla, so here it is.  I also have a core file which I will save and will
provide upon request.  Due to its large size, it may be necessary for you
to acquire it from me via our University large file server--I will send
instructions and a password on request--but please provide an email where
these instructions should be sent, as it is a scripted process that I cannot
modify.
George Reeke
Rockefeller University
Comment 3 George Reeke 2008-11-12 12:09:02 EST
Sorry, I do not have a core dump file--the one mentioned in Comment #2 was
from some other program.  Please disregard that part of my comment.
George Reeke
Rockefeller University
Comment 4 James Antill 2008-11-12 12:33:12 EST
 The error is:

TypeError: Parsing primary.xml error: Extra content at the end of the document

...can you show the data that's at the end of /var/cache/yum/*/primary.xml.gz ... also can you show what repos you have available (yum repolist)?
Comment 5 George Reeke 2008-11-12 14:10:57 EST
Created attachment 323372 [details]
Requested ending of primary.xml.gz file

You did not say how much of primary.xml.gz you would like to see--I
arbitrarily sent last 1000 lines.
The output of the command 'yum repolist' is as follows:

Loading "rhnplugin" plugin
repo id              repo name                                 status
rhel-x86_64-server-5 None                                      enabled

George Reeke
Comment 6 George Reeke 2008-11-13 17:50:42 EST
With today's (Nov. 13, 2008) RedHat updates, it "just worked".  I didn't
change anything except installed new 2.6.18-92.1.18.el5 kernel yesterday
(when the pup notifier failed, I did a "yum update" and the update worked
normally).
So maybe that kernel change fixed it, but that seems unlikely.  I will
enter another comment if this fails again.  Sorry I can no longer
reproduce this issue for you.

George Reeke
Comment 8 Sebastian Skracic 2010-10-07 04:29:56 EDT

*** This bug has been marked as a duplicate of bug 452538 ***

Note You need to log in before you can comment on or make changes to this bug.