Bug 466469 - Firefox 3 silently fails to write downloaded files
Firefox 3 silently fails to write downloaded files
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xulrunner (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
: Reopened, Triaged
Depends On: 509156 684926
Blocks: 499522
  Show dependency treegraph
 
Reported: 2008-10-10 08:52 EDT by Olivier Fourdan
Modified: 2014-01-17 07:36 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 684926 (view as bug list)
Environment:
Last Closed: 2011-07-06 13:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to fix the issue (707 bytes, patch)
2008-10-10 08:52 EDT, Olivier Fourdan
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 429827 None None None Never
Mozilla Foundation 462869 None None None Never

  None (edit)
Description Olivier Fourdan 2008-10-10 08:52:31 EDT
Created attachment 320012 [details]
Proposed patch to fix the issue

Description of problem:

When saving a file to a non user writable directory, Firefox 3 give no notification to the user but an exception error in the log:

Version-Release number of selected component (if applicable):

firefox-3.0.1

The problem is also still present in upstream built.

How reproducible:

100% reproducible

Steps to Reproduce:
1. Download a file
2. Use "Save to disk" instead of "Open with"
3. Select a destination directory that is not writable to the user
  
Actual results:

There is no notification of failure to the user but a message in the console (if FF3 was started from a terminal):

*** exception in validateLeafName: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.create]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: file:///usr/lib/xulrunner-1.9/components/nsHelperAppDlg.js :: anonymous :: line 271"  data: no]

Expected results:

A dialog box notifying that the file was not saved.

Additional info:

The problem is also present upstream and I did not find a bug report about this on mozilla.org.

The fix is actually fairly simple, in "nsHelperAppDlg.js", the call to aLocalFile.create() must be protected by a try/catch.

The proposed patch attached gives the expected result. Note: I can open a BZ upstream to get the fix upstream too if that helps, just let me know.
Comment 1 Matěj Cepl 2008-11-03 11:53:10 EST
Please file a bug report in the the upstream bugzilla located at http://bugzilla.mozilla.org in the particular component. Given that you are providing the patch, it would be probably really better, if you were in the direct contact with upstream.

Once you've filed your bug report to the upstream bugzilla, if you paste the new bug URL here, Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.
Comment 2 Olivier Fourdan 2008-11-03 12:27:23 EST
Bugzilla upstream created - I've also updated the external bug field, copying hthe URL here for completion:

https://bugzilla.mozilla.org/show_bug.cgi?id=462869

Cheers,
Olivier.
Comment 3 Matěj Cepl 2008-11-04 12:06:54 EST
Closing as UPSTREAM.
Comment 19 RHEL Product and Program Management 2010-05-20 08:48:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Note You need to log in before you can comment on or make changes to this bug.