Bug 466506 - Upgrading issues with RH5.1 Workstation via RHN
Upgrading issues with RH5.1 Workstation via RHN
Status: CLOSED NOTABUG
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Orazi
Red Hat Network Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 12:28 EDT by Pavel Mironchyk
Modified: 2013-01-10 05:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 10:25:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Mironchyk 2008-10-10 12:28:39 EDT
Description of problem:
Cannot upgrade my new system 5.1 with RHN...

How reproducible:
always

Steps to Reproduce:
1. Install newly 5.1 Workstation
2. Register system in RHN
3. Upgrade via Yum
  
Actual results:
Upgrade terminates with error: see below

Expected results:
Ok

Additional info:
--> Running transaction check
Error: Missing Dependency: libgcj = 4.1.2-14.el5 is needed by package libgcj-devel
Error: Missing Dependency: libX11 = 1.0.3-8.0.1.el5 is needed by package libX11-devel
Error: Missing Dependency: libstdc++ = 4.1.2-14.el5 is needed by package libstdc++-devel
Error: Missing Dependency: rpm = 4.4.2-47.el5 is needed by package rpm-build
Error: Missing Dependency: mysql = 5.0.22-2.1.0.1 is needed by package mysql-server
Error: Missing Dependency: ImageMagick = 6.2.8.0-3.el5.4 is needed by package ImageMagick-devel
Error: Missing Dependency: java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.112 is needed by package java-1.4.2-gcj-compat-devel
Error: Missing Dependency: openldap = 2.3.27-8 is needed by package openldap-devel
Error: Missing Dependency: ghostscript = 8.15.2-9.1.el5 is needed by package ghostscript-devel
Error: Missing Dependency: mysql = 5.0.22-2.1.0.1 is needed by package mysql-devel
Error: Missing Dependency: cairo = 1.2.4-2.el5 is needed by package cairo-devel
Error: Missing Dependency: apr-util = 1.2.7-6 is needed by package apr-util-devel
Error: Missing Dependency: e2fsprogs-libs = 1.39-10.el5 is needed by package e2fsprogs-devel
Error: Missing Dependency: libselinux = 1.33.4-4.el5 is needed by package libselinux-devel
Error: Missing Dependency: libpng = 2:1.2.10-7.0.2 is needed by package libpng-devel
Error: Missing Dependency: ruby-libs = 1.8.5-5.el5 is needed by package ruby-devel
Error: Missing Dependency: libgcj = 4.1.2-14.el5 is needed by package gcc-java
Error: Missing Dependency: freetype = 2.2.1-19.el5 is needed by package freetype-devel
Error: Missing Dependency: libtiff = 3.8.2-7.el5 is needed by package libtiff-devel
Error: Missing Dependency: gcc = 4.1.2-14.el5 is needed by package gcc-c++
Error: Missing Dependency: krb5-libs = 1.6.1-17.el5 is needed by package krb5-devel
Error: Missing Dependency: gcc = 4.1.2-14.el5 is needed by package gcc-java
Error: Missing Dependency: libstdc++ = 4.1.2-14.el5 is needed by package gcc-c++
Error: Unable to satisfy dependencies
Error: Package libgcj-devel needs libgcj = 4.1.2-14.el5, this is not available.
Error: Package libX11-devel needs libX11 = 1.0.3-8.0.1.el5, this is not available.
Error: Package libstdc++-devel needs libstdc++ = 4.1.2-14.el5, this is not available.
Error: Package rpm-build needs rpm = 4.4.2-47.el5, this is not available.
Error: Package mysql-server needs mysql = 5.0.22-2.1.0.1, this is not available.
Error: Package ImageMagick-devel needs ImageMagick = 6.2.8.0-3.el5.4, this is not available.
Error: Package java-1.4.2-gcj-compat-devel needs java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.112, this is not available.
Error: Package openldap-devel needs openldap = 2.3.27-8, this is not available.
Error: Package ghostscript-devel needs ghostscript = 8.15.2-9.1.el5, this is not available.
Error: Package e2fsprogs-devel needs e2fsprogs-libs = 1.39-10.el5, this is not available.
Error: Package mysql-devel needs mysql = 5.0.22-2.1.0.1, this is not available.
Error: Package cairo-devel needs cairo = 1.2.4-2.el5, this is not available.
Error: Package libpng-devel needs libpng = 2:1.2.10-7.0.2, this is not available.
Error: Package openssl-devel needs openssl = 0.9.8b-8.3.el5_0.2, this is not available.
Error: Package apr-util-devel needs apr-util = 1.2.7-6, this is not available.
Error: Package ruby-devel needs ruby-libs = 1.8.5-5.el5, this is not available.
Error: Package gcc-java needs libgcj = 4.1.2-14.el5, this is not available.
Error: Package freetype-devel needs freetype = 2.2.1-19.el5, this is not available.
Error: Package libselinux-devel needs libselinux = 1.33.4-4.el5, this is not available.
Error: Package libtiff-devel needs libtiff = 3.8.2-7.el5, this is not available.
Error: Package gcc-c++ needs gcc = 4.1.2-14.el5, this is not available.
Error: Package krb5-devel needs krb5-libs = 1.6.1-17.el5, this is not available.
Error: Package gcc-java needs gcc = 4.1.2-14.el5, this is not available.
Error: Package gcc-c++ needs libstdc++ = 4.1.2-14.el5, this is not available.
Comment 1 James Bowes 2008-10-14 09:07:31 EDT
Hi Pavel:

It looks like your system is subscribed to the RHEL Desktop channel, but not the RHEL Desktop Workstation child channel. If you subscribe to that via the web ui, you should be able to update successfully.
Comment 2 Pavel Mironchyk 2008-10-14 10:25:21 EDT
Hi James,

Thanks, now issue is solved...

Note You need to log in before you can comment on or make changes to this bug.