Bug 466519 - [utrace] Kernel crashes after pressing Ctrl+C to interrupt certain process.
[utrace] Kernel crashes after pressing Ctrl+C to interrupt certain process.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 14:02 EDT by Konstantin Andreev
Modified: 2008-11-01 22:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.26.6-79.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-01 22:43:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel diagnostic messages at console during crash. (4.35 KB, text/plain)
2008-10-10 14:02 EDT, Konstantin Andreev
no flags Details

  None (edit)
Description Konstantin Andreev 2008-10-10 14:02:29 EDT
Created attachment 320037 [details]
Kernel diagnostic messages at console during crash.

Description of problem:
   When I run certain foreground process in terminal windows, then press Ctrl+C to interrupt it, kernel suddenly crashes.

Version-Release number of selected component (if applicable):
   I have installed the stock Fedora 9 x86_64. The kernel version is "2.6.25-14.fc9.x86_64".
   The application I run is "1C_Enterprise-8.1.11-67.x86_64", if it matters.

Steps to Reproduce:
1. Run in terminal window: /opt/1C/v8.1/x86_64/ragent
2. Play a little with this 1C server from remote management console.
3. Press Ctrl+C in terminal window to interrupt ragent.
  
Actual results:
   Kernel crashes and prints diagnostic messages to system console, - see Attachement.

Additional info:
   I have captured kernel diagnostic messages to console by redirecting console to serial port.
Comment 1 Konstantin Andreev 2008-10-10 14:09:11 EDT
The hardware I use: 
   IBM System x3550 -[7978KCG], 
   2Gb of main memory
   1 Intel Xeon E5335 -SLAEK (4 cores) @ 2.00GHz : http://processorfinder.intel.com/details.aspx?sSpec=SLAEK#
Comment 2 Roland McGrath 2008-10-14 15:09:12 EDT
Please verify on a current update kernel.
Comment 3 Chuck Ebbert 2008-10-20 14:53:27 EDT
Please verify with kernel-2.6.26.6-79.fc9
Comment 4 Konstantin Andreev 2008-10-28 08:59:07 EDT
Verified, - NOT reproduced with kernel 2.6.26.6-79.fc9.x86_64.

Note You need to log in before you can comment on or make changes to this bug.