Bug 466525 - anaconda from boot.iso does not ask for keyboard layout in rescue mode
anaconda from boot.iso does not ask for keyboard layout in rescue mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 465687 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 14:35 EDT by Till Maas
Modified: 2008-10-22 14:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 16:28:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2008-10-10 14:35:38 EDT
Description of problem:
I downloaded boot.iso from
http://mirror.fraunhofer.de/download.fedora.redhat.com/fedora/linux/development/i386/os/images/
with filedate 2008-10-10 and started into rescue mode on a qemu-kvm i386
machine. Anaconda does not ask for the keyboard layout during the process, therefore it sucks to enter a crypto password with a non english keyboard or it is impossible with keyboards that doe note have the required characters, e.g. umlauts.

Version-Release number of selected component (if applicable):
11.4.1.45

How reproducible:
always

Steps to Reproduce:
1. boot anaconda rescue mode from boot.iso with encrypted volumes
2. go to the enter passphrase for crypto devices window
  
Actual results:
Cannot type passphrases containg öäü, y and z are at the wrong location, ...

Expected results:
I should be asked for the keyboard layout.
Comment 1 Chris Lumens 2008-10-10 16:28:28 EDT
We used to do this, but I broke it when I removed these steps from the list when you boot with the boot.iso.  That affects rescue mode too.  This will be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 2 Chris Lumens 2008-10-22 14:41:19 EDT
*** Bug 465687 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.