Bug 466569 - Update the igb driver with RHEL5.3 and upstream fixes
Update the igb driver with RHEL5.3 and upstream fixes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
1.1
All Linux
high Severity medium
: Next Version
: ---
Assigned To: Arnaldo Carvalho de Melo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 17:42 EDT by Clark Williams
Modified: 2009-07-08 11:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-08 11:34:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clark Williams 2008-10-10 17:42:56 EDT
Description of problem:

Need to update the MRG RT igb driver with RHEL5.3 and upstream fixes
Comment 1 Luis Claudio R. Goncalves 2008-10-28 13:53:29 EDT
Added to -89
Comment 3 Clark Williams 2008-12-03 17:09:54 EST
Pulled from 1.1 errata due to inability to test; retargeted for 1.1.1 errata
Comment 4 Adam Gibson 2008-12-17 13:53:26 EST
Will the 5.3 version fix the bug where the link shows as no with ethtool but if you issue a ethtool -r the interface link status switches to yes?  I found a thread on the E1000-devel list that explains my problems exactly.  It seems the link state interrupts are being lost somehow.

The servers are Dell PowerEdge R200 with the following Intel Pro 1000 VT Quad portcard:
driver: igb
desc: "Intel Corporation 82575GB Gigabit Network Connection"
vendorId: 8086
deviceId: 10d6
subVendorId: 8086
subDeviceId: 145a

This is a huge issue for me on 5.2 because I was about to deploy two new firewalls but the interfaces stop working at times if unplugged and plugged back in it seems.  Or if you plug an interface in after power on.

The E1000-devel link that I mentioned is here:
http://www.mail-archive.com/e1000-devel@lists.sourceforge.net/msg00609.html

If this is not known I will file a bug report.  I just hope it can get fixed.
Comment 5 Clark Williams 2009-07-08 11:34:23 EDT
updated drivers delivered, no h/w to test

Note You need to log in before you can comment on or make changes to this bug.