Bug 466609 - postfix-2.5.5-1.fc8 does not run with Dovcot SASL; has wrong selinux context on /var/lib/postfix
postfix-2.5.5-1.fc8 does not run with Dovcot SASL; has wrong selinux context ...
Status: CLOSED DUPLICATE of bug 466235
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
8
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-11 03:51 EDT by John Griffiths
Modified: 2008-10-14 09:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 06:51:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Griffiths 2008-10-11 03:51:32 EDT
Description of problem:
Two problems with the postfix-2.5.5-1.fc8 release.
1) wrong selinux context on /var/lib/postfix - can be worked around
2) Postfix runs but does not accept email.

Version-Release number of selected component (if applicable):
postfix-2.5.5-1.fc8

How reproducible:
Always

Steps to Reproduce:
1.Install postfix-2.5.5-1.fc8
2.postfix stops but does not restart
3.restart postfix
4.try to send email
  
Actual results:
1) selinux context is var_lib_t on /var/lib/postfix and selinux prevents postfix from using it.

2) email is not sent. 
   Error in maillog is:
/var/log/maillog:Oct 11 03:27:20 gei postfix/smtpd[8869]: fatal: no SASL authentication mechanisms
   Dovecot SASL is configured:
main.cf:smtpd_sasl_auth_enable = yes
main.cf:smtpd_sasl_security_options = noplaintext noanonymous
main.cf:broken_sasl_auth_clients = yes
main.cf:smtpd_sasl_type = dovecot
main.cf:smtpd_sasl_path = private/auth


Expected results:
email should be accepted and sent.

Additional info: see above
Comment 1 Thomas Woerner 2008-10-14 06:51:21 EDT

*** This bug has been marked as a duplicate of bug 466235 ***
Comment 2 John Griffiths 2008-10-14 09:01:56 EDT
This is not a duplicate of 466235. There are two issues reported in this bug only one of which is covered in 466235.

The greater issue reported in this bug is that Postfix does not recognize Dovecot SASL.

Repeat from above:
 postfix-2.5.5-1.fc8 does not run with Dovcot SASL

Postfix runs but does not accept email.

   Error in maillog is:
/var/log/maillog:Oct 11 03:27:20 gei postfix/smtpd[8869]: fatal: no SASL authentication mechanisms

But Dovecot SASL is configured:

main.cf:smtpd_sasl_auth_enable = yes
main.cf:smtpd_sasl_security_options = noplaintext noanonymous
main.cf:broken_sasl_auth_clients = yes
main.cf:smtpd_sasl_type = dovecot
main.cf:smtpd_sasl_path = private/auth

Please reopen.

Note You need to log in before you can comment on or make changes to this bug.