Bug 46667 - System does not start after install
System does not start after install
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-06-29 15:13 EDT by Scott Wedel
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-25 18:03:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Scott Wedel 2001-06-29 15:13:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows 98; Win 9x 4.90)

Description of problem:
After install of Red Hat Linux 7.1, the system will not boot up, hanging 
at "Configuring Kernel Modules".

How reproducible:

Steps to Reproduce:
1. Run the Red Hat installer, either graphical or text
2. Reboot after install to start system

(please see below for machine configuration)

Actual Results:  System will not start, instead hanging at "Configuring 
Kernel Modules".  Pressing Ctrl-C produces the following:

/etc/rc.d/rc: /var/run/runlevel.dir: Read-only file system 
updating /etc/fstab failed to open /etc/fstab.NEW: Read-only file system.

Then, Checking for new hardware is successful, leading to:

/var/lock/subsys/kudzu: Read-only file system.

Then, Setting network parameters and Bringing up interface lo run.  The 
next error is: 
/var/lock/subsys: Read-only file system

A lot more errors show up after Starting System Logger... runs for awhile, 
all of them having to do with read-only file system.  Finally, the system 
gets stuck in a loop where the following message is repeated over and over 
for each ID process:

INIT: Id "1" respawning too fast: disabling for 5 minutes. It does this 
for Id "1" through "6". 

At this point, the system must be rebooted.  Ctrl-Alt-Del produces a few 
error messages, finally hanging (requiring a hard power off) at "Setting 
system clock to hardware clock".

Expected Results:  RHL 7.1 should come up and run normally.

Additional info:

System configuration:

ASUS PSB-F motherboard w/IDE controller on board
512 MB RAM
Samsung 40GB IDE HD
Creative 52X IDE CD-ROM
no net card, no sound card
ATI Xpert 128 video w/16MB RAM, PCI
Philips 109S monitor
MS wheel mouse and Natural Keyboard
Comment 1 Brent Fox 2001-06-29 23:46:30 EDT
Weird.  Did anything strange happen during the install or did everything go
Comment 2 Scott Wedel 2001-06-30 01:28:33 EDT
The installer completed as normal; no problems evidenced.  Looks like it 
finishes happily, although the video card is incorrectly detected (which is a 
separate bug) and therefore Xconfigurator fails.
Comment 3 Brent Fox 2001-07-03 16:20:16 EDT
Can you run 'ddcprobe' and attach the output?  Also, can you attach you
/etc/modules.conf file?
Comment 4 Scott Wedel 2001-07-03 16:39:34 EDT
I can't run ANYTHING.  The system does not come up, AT ALL.  Therefore, I never 
get shell access to run what you're looking for.
Comment 5 Brent Fox 2001-07-03 18:09:47 EDT
Is this related to bug #46686 that you filed?  It seems like you are having a
couple of different problems at the same time.  Have you tried just starting
over and installing again?  I would recommend using text mode and try skipping
the video card test.
Comment 6 Scott Wedel 2001-07-03 18:15:39 EDT
I've done that.  The system still doesn't come up, and spits out the same 
errors as before.  I'm not sure it's ever getting to the point where X is 
started, to be honest, before it hangs.
Comment 7 Brent Fox 2001-07-10 12:38:59 EDT
Well, it sounds like it's trying to start X, and then having a problem.  What I
meant to suggest to you was to do an install and select text login instead of
graphical login.  If you can get the system to at least come up to the text
login prompt, we can then try running X manually.  
I saw a problem like this a few months ago, but I can't remember what the
problem was.  I know that the ATI Xpert 128 cards work, though.
Comment 8 Scott Wedel 2001-07-10 14:22:36 EDT
Well ... I've done that, too.  I never get to a prompt of any type - it just 
hangs up at Configuring System Modules and then spits out all the error 
messages which I listed earlier in the bug, finally hanging up in the ID "1" 
etc. loop.

Comment 9 Brent Fox 2001-07-18 12:36:51 EDT
Really?  You selected text login and it's still doing this?
Comment 10 Scott Wedel 2001-07-18 17:45:28 EDT
Absolutely.  No matter what login type I select, I never even get to a login 
prompt.  The system hangs on boot, giving the error messages described earlier 
in this bug report.
Comment 11 Brent Fox 2001-07-23 11:48:48 EDT
Wow.  I'm stumped.  I can't think of anything else to try.
Comment 12 Scott Wedel 2001-07-25 18:03:21 EDT
I'm stumped too, as well as a few knowledgable friends.  Right now, I suspect 
the hard disk.  After downloading the .ISO images for 6.2 I burned CDs, but 6.2 
did the EXACT same thing as 7.1.

We also replaced the video card, to a Matrox Mystique 4 MB card that I had 
lying around in a box in a closet.  Handy :)

I'm attempting to install (evil) Windows ME on the machine now, just to see if 
ANY installation will take.  If not, the next step is to replace the hard 
disk.  I'll keep you posted, if you like.
Comment 13 Brent Fox 2001-07-26 14:51:42 EDT
I hate to close this bug, but it just seems to go in the category of the
unexplainable, so I don't know what else to do.  It does sound like a hardware
problem to me since 6.2 didn't work either, and it had a completely different
kernel than 7.1  If you see this problem appear on any other machines, please
reopen this bug.  Feel free to keep posting, though, about what you find with

Note You need to log in before you can comment on or make changes to this bug.