Bug 466674 - RFE: upgrade subversion to 1.5.3 (and specfile change)
RFE: upgrade subversion to 1.5.3 (and specfile change)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-12 12:05 EDT by Jose Pedro Oliveira
Modified: 2008-11-01 17:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-13 16:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2008-10-12 12:05:24 EDT
Description of problem:
Version 1.5.3 of subversion has been released.

Version-Release number of selected component (if applicable):
rawhide: subversion-1.5.2-3.src.rpm 

Expected results:
To have subversion 1.5.3 RPMS in rawhide.

Additional info:

Major changes (source http://svn.collab.net/repos/svn/tags/1.5.3/CHANGES)

Version 1.5.3
(10 Oct 2008, from /branches/1.5.x)
http://svn.collab.net/repos/svn/tags/1.5.3

 User-visible changes:
  * Allow switch to continue after deleting locally modified dirs (issue #2505)
  * Update bash_completion to be compatible with 1.5 (r32900, -11, -12)
  * Improve 'svn merge' execution time by 30% on Windows (r33447)
  * Reuse network sessions during 'svn merge', improving performance (r33476)
  * Improve temp file creation time on Windows (r33464)
  * Greatly improve merge performance (r29969, r32463, r33013, -016, -022, -112)
  * Improve file IO performance on Windows (r33178, -85)
  * fixed: merging files with spaces in name (r33109, -121, -369)
  * fixed: incorrect relative externals expansion (r33109, -121, -369)
  * fixed: 'svn mv' hangs and consumes infinite memory (r33201, -12)
  * fixed: correctness regression in 'svn log -g' (issue #3285)
  * fixed: current early bailout of 'svn log -g' (r32977)

 Developer-visible changes:
  * Allow the tests to run as non-administrator on Windows Vista (r31203)
  * Allow out-of-tree build of bindings on BSD (r32409)
  * Translate messages in svn_fs_util.h (r32771)
  * fixed: bindings test for Perl 5.10 (r31546)
  * fixed: building bindings and C API tests with VS2008 (r32012)
  * fixed: svn_ra_replay API over ra_serf (r33173)
Comment 1 Jose Pedro Oliveira 2008-10-12 12:11:32 EDT
Joe, 

Would it also be possible to apply the following changes to the specfile?

 * change the source subversion tarball to the bz2 version
   (Source0:  .gz --> .bz2)

 * append "%{?dist}" to the Release line
   (e.g.:   Release: 1.%{?dist})

/jpo
Comment 2 Jose Pedro Oliveira 2008-10-12 12:22:09 EDT
Joe,

I believe the Source4 (the emacs file) can be dropped as it is now included in the subversion tarball:

  $ tar tzf subversion-1.5.3.tar.gz | grep psvn
  subversion-1.5.3/contrib/client-side/emacs/psvn.el

Note: It also appears to be a more recent copy.

/jpo
Comment 3 Joe Orton 2008-10-13 16:24:38 EDT
Thanks for the report & feedback - 1.5.3 update now in Raw Hide - otherwise:

1) .gz vs .bz2 seems like a bikeshed; not mandated by the packaging standards AFAIK?
2) dist I prefer without for devel; not mandated by the packaging guidelines
3) psvn.el is shipped separately since the copy in the tarball is rarely up to date; though that is true of the shipped copy too.  I updated it, but if you want to help out with keeping it up-to-date, that would be great!
Comment 4 Jose Pedro Oliveira 2008-10-18 23:38:35 EDT
(In reply to comment #3)
> Thanks for the report & feedback - 1.5.3 update now in Raw Hide - otherwise:

Thanks for the rawhide update.

> 1) .gz vs .bz2 seems like a bikeshed; not mandated by the packaging standards
> AFAIK?

I considered this a good engineering practice - using the .bz2 tarball you have
the same results using less disk space (25% in this case) and less bandwidth.

> 2) dist I prefer without for devel; not mandated by the packaging guidelines

It helps people like me tracking specfiles changes when we test/rebuild rawhide packages in older fedora distros.

jpo
Comment 5 Jose Pedro Oliveira 2008-10-26 14:46:31 EDT
New subversion release


Version 1.5.4
(24 Oct 2008, from /branches/1.5.x)
http://svn.collab.net/repos/svn/tags/1.5.4

 User-visible changes:
  * Properly handle explicit mergeinfo added in merge source (r32968, -75)
  * fixed: merging of paths containing spaces (r33641, -44)
  * fixed: regression in mergeinfo-aware merges against 1.5.3 (r33693, -704)
Comment 6 Joe Orton 2008-10-27 05:21:46 EDT
1.5.4 is on its way to Raw Hide.
Comment 7 Jose Pedro Oliveira 2008-10-27 20:58:50 EDT
(In reply to comment #6)
> 1.5.4 is on its way to Raw Hide.

Thanks for the update!

There is a rpath problem in 64bit systems.  The SRPM rebuild fails in x86_64
systems with rpmdevtools installed and the /usr/lib/rpm/check-rpaths active:
----------
...
ERROR   0001: file '/usr/bin/svndumpfilter' contains a standard rpath '/usr/lib64' in [/usr/lib64]
ERROR   0001: file '/usr/bin/svnserve' contains a standard rpath '/usr/lib64' in [/usr/lib64]
error: Bad exit status from /var/tmp/rpm-tmp.hylxe6 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.hylxe6 (%install)
----------
Comment 8 Jose Pedro Oliveira 2008-10-27 21:23:13 EDT
A couple of questions about the apr version requirements:

  From the specfile:
  ---------
  ...
  BuildRequires: apr-devel >= 0.9.7, apr-util-devel >= 0.9.7
  ...
  Requires: apr >= 1.3.0
  ...
  ---------

Any particular reason for the version differences between the build requirement
and the requirement (0.9.7 vs 1.3.0) ?  

And why the 1.3.0 requirement?  At the end of the subversion 1.5 release notes
(http://subversion.tigris.org/svn_1.5_releasenotes.html) they only mention APR 1.x.
Comment 9 Joe Orton 2008-10-28 05:20:10 EDT
Jose - could you file new bugs about new problems, and send general questions to fedora-devel?  Helps me to manage my bugspam ;)

(The 1.3.0 is there because once built against 1.3.0, symbols from 1.3.0 are required, so the BRs should be bumped up really too)
Comment 10 Jose Pedro Oliveira 2008-11-01 17:53:27 EDT
(In reply to comment #9)
> Jose - could you file new bugs about new problems, and send general questions
> to fedora-devel?  Helps me to manage my bugspam ;)

Done (tickets #469524 and #469525).

Note You need to log in before you can comment on or make changes to this bug.