Bug 466697 - enable http-keepalive and pipelining
enable http-keepalive and pipelining
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
devel
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-12 19:11 EDT by Till Maas
Modified: 2013-06-23 22:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 01:26:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2008-10-12 19:11:39 EDT
Description of problem:

Currently the webserver for bugzilla sends a Connection: close header in each response and closes the connection. Therefore a webbrowser has to open a new connection for each requests. These requests are ssl encrypted and there it takes quite long to open a new connection. If keep-alive was enabled, the browser can reuse an establised connection and therefore it will take less time to request a complete bugzilla page.
Comment 1 David Lawrence 2008-11-21 15:52:09 EST
Matt, is this something that we can now address with GIT to see if they we can enable this on our webapps?
Comment 2 Matthew Schick 2008-11-21 16:06:07 EST
This is something that we scrapped due to issues IT has seen with their other apps in the DC.  If we were using some dedicated static content servers it would be useful, but for dynamic it's not so much.
Comment 3 Till Maas 2009-04-23 16:43:26 EDT
(In reply to comment #2)
> This is something that we scrapped due to issues IT has seen with their other
> apps in the DC.  If we were using some dedicated static content servers it
> would be useful, but for dynamic it's not so much.  

There are a log of probably static CSS and Javascript files that get loaded for every request, there seem to be around 19 requests for such extra files for one bug report. Now each of these requests take at least the time for one SSL-Handshake, even if they return a 404.
Comment 4 Jeff Fearn 2012-05-30 00:45:00 EDT
As part of the recent Bugzilla 4.2 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 5 Jeff Fearn 2012-05-30 00:45:03 EDT
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 6 Jeff Fearn 2012-07-19 01:26:19 EDT
As noted previously, the Bugzilla Team is cleaning up a large number of outstanding issues that have bit rotted. This bug is being closed as there has been no response to that notification.

If you believe this bug is still important please reopen this bug in the NEW status and PM will consider it.

Note You need to log in before you can comment on or make changes to this bug.