Bug 466716 - "hts clean" will not clean the results/config files which are appointed by user
"hts clean" will not clean the results/config files which are appointed by user
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
: 466722 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 03:35 EDT by Yolkfull Chow
Modified: 2014-03-25 20:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:57:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2008-10-13 03:35:41 EDT
Description of problem:
After running hts with argument -c customized_config.xml(or -r customized_results.xml) to appoint a config file manually, and then issue "hts clean" to clean all results and temporary files, the customized_config.xml file will NOT be cleaned.
Hts help page:
command:
        clean - remove all results and temporary files



Version-Release number of selected component (if applicable):
hts-5.2-20.el4.noarch

How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
It should clean all results/config/plan files both generated by system and appointed by user.

Additional info:
Comment 2 Greg Nichols 2008-10-13 12:07:33 EDT
What specific syntax was used to the "hts clean" command?

If -r is used on "hts plan", it must also be used on "hts clean".
Comment 3 Yolkfull Chow 2008-10-13 21:48:37 EDT
(In reply to comment #2)
> What specific syntax was used to the "hts clean" command?
> 
> If -r is used on "hts plan", it must also be used on "hts clean".

You mean if want to clean customized_plan.xml, we need "hts clean -p customized_plan.xml"? 
And accordingly if want to clean customized_config.xml/customized_results.xml, we need to "hts clean -c customized_config.xml" and "hts clean -r customized_results.xml" ? But all the three will failed. And moreover,"hts clean" will also not clean any temporary data files generated by hts test under /tmp/.
Comment 4 Greg Nichols 2008-10-15 10:32:15 EDT
*** Bug 466722 has been marked as a duplicate of this bug. ***
Comment 9 Yan Tian 2009-01-12 20:39:19 EST
Verified this bug was not found in hts-5.3-12.
Comment 11 errata-xmlrpc 2009-01-27 17:57:58 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0047.html

Note You need to log in before you can comment on or make changes to this bug.