Bug 466722 - Hts failed to clean after appointing a directory for data files
Hts failed to clean after appointing a directory for data files
Status: CLOSED DUPLICATE of bug 466716
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 04:10 EDT by Yolkfull Chow
Modified: 2014-03-25 20:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 10:32:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yolkfull Chow 2008-10-13 04:10:35 EDT
Description of problem:
After appointing a directory for data files,hts clean will fail to clean config.xml and plan.xml files.

Version-Release number of selected component (if applicable):
hts-5.2-20.el4

How reproducible:
Everytime

Steps to Reproduce:
1. hts plan -n $IP -d /tmp/hts
2. go to directory /tmp/hts, you could see the config.xml and plan.xml are saved here
3. after issue "hts clean", config.xml and plan.xml are not cleaned at all.
  
Actual results:


Expected results:


Additional info:
Comment 2 Greg Nichols 2008-10-13 12:05:18 EDT
The correct command for cleaning the test results/plan would be:

hts clean -d /tmp/hts

Is that what you used?
Comment 3 Yolkfull Chow 2008-10-13 21:32:12 EDT
(In reply to comment #2)
> The correct command for cleaning the test results/plan would be:
> 
> hts clean -d /tmp/hts
> 
> Is that what you used?

Hi Greg,

Firstly,in HTS help page(hts --help),it doesn't hint any info that if user appoint a data directory he will need add an argument when "hts clean", whereas only telling "hts clean" will "remove all results and temporary files".

Secondly, "hts clean -d /tmp/hts" will failed as well.
Comment 4 Greg Nichols 2008-10-15 10:32:15 EDT

*** This bug has been marked as a duplicate of bug 466716 ***

Note You need to log in before you can comment on or make changes to this bug.