Bug 466728 - Package rhnpush-5.1.0-8.noarch.rpm is both in RHEL 4 and RHEL 5 composes
Package rhnpush-5.1.0-8.noarch.rpm is both in RHEL 4 and RHEL 5 composes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Release (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Steve Salevan
:
Depends On:
Blocks: 446877
  Show dependency treegraph
 
Reported: 2008-10-13 05:40 EDT by Jan Pazdziora
Modified: 2008-11-05 13:42 EST (History)
3 users (show)

See Also:
Fixed In Version: sat520
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 13:42:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2008-10-13 05:40:27 EDT
Description of problem:

Package rhnpush-5.1.0-8.noarch.rpm is both in RHEL 4 and RHEL 5 composes.
That is not good because we will need different signature keys for those
different OSes.

Version-Release number of selected component (if applicable):

Satellite-5.2.0-RHEL4-re20081010.0
Satellite-5.2.0-RHEL5-re20081010.0

How reproducible:

Deterministic.

Steps to Reproduce:
1. $ ls -la /mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL5-re20081010.0/i386/i386/Satellite/rhnpush-5.1.0-8.noarch.rpm 
-rw-r--r-- 563 root root 96694 2008-04-14 19:55 /mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL5-re20081010.0/i386/i386/Satellite/rhnpush-5.1.0-8.noarch.rpm
$ ls -la /mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL4-re20081010.0/i386/i386/Satellite/rhnpush-5.1.0-8.noarch.rpm 
-rw-r--r-- 563 root root 96694 2008-04-14 19:55 /mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL4-re20081010.0/i386/i386/Satellite/rhnpush-5.1.0-8.noarch.rpm

Actual results:

The same file (same name and all).

Expected results:

The files should not be the same.

Additional info:
Comment 1 Jan Pazdziora 2008-10-14 03:45:19 EDT
Packages rhnpush-5.2.0-1.el5 and rhnpush-5.2.0-1.el4 built and tagged.
Comment 2 Jan Pazdziora 2008-10-14 07:27:47 EDT
I've checked that the *.py does not differ from rhnpush-5.1.1-1.noarch.rpm.
Comment 3 Jan Pazdziora 2008-10-14 07:30:21 EDT
New composes Satellite-5.2.0-RHEL4-re20081014.1 and Satellite-5.2.0-RHEL5-re20081014.1 were made, moving ON_QA.
Comment 4 Steve Salevan 2008-10-15 11:03:04 EDT
rhnpush-5.2.0-1.el4 packages found in all RHEL 4 composes.
rhnpush-5.2.0-1.el5 packages found in all RHEL 5 composes.
As thus, moving to VERIFIED.
Comment 5 Jeff Browning 2008-10-16 01:09:29 EDT
rhnpush-5.2.0-1.el4 and el5 are in their respective composes.

Verified.
Comment 6 Preethi Thomas 2008-10-22 11:25:33 EDT
release pending
Comment 7 Brandon Perkins 2008-11-05 13:42:41 EST
5.2.0 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.