Bug 466730 - Package servletapi4-4.0.4-3jpp_5rh.noarch.rpm is both in RHEL 4 and RHEL 5 composes
Package servletapi4-4.0.4-3jpp_5rh.noarch.rpm is both in RHEL 4 and RHEL 5 co...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Release (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Preethi Thomas
:
Depends On:
Blocks: 446877
  Show dependency treegraph
 
Reported: 2008-10-13 05:45 EDT by Jan Pazdziora
Modified: 2008-11-05 13:42 EST (History)
2 users (show)

See Also:
Fixed In Version: sat520
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 13:42:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2008-10-13 05:45:38 EDT
Description of problem:

Package servletapi4-4.0.4-3jpp_5rh.noarch.rpm is both in RHEL 4 and RHEL 5
composes. That is not good because we will need different signature keys for
those different OSes.

Version-Release number of selected component (if applicable):

Satellite-5.2.0-RHEL4-re20081010.0
Satellite-5.2.0-RHEL5-re20081010.0

How reproducible:

Deterministic.

Steps to Reproduce:
1. $ ls -la /mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL5-re20081010.0/i386/i386/Satellite/servletapi4-4.0.4-3jpp_5rh.noarch.rpm 
-rw-r--r-- 3302 root root 75341 2005-12-11 20:55 /mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL5-re20081010.0/i386/i386/Satellite/servletapi4-4.0.4-3jpp_5rh.noarch.rpm
$ ls -la /mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL4-re20081010.0/i386/i386/Satellite/servletapi4-4.0.4-3jpp_5rh.noarch.rpm 
-rw-r--r-- 3302 root root 75341 2005-12-11 20:55 /mnt/redhat/devel/candidate-trees/Satellite-5.2.0-RHEL4-re20081010.0/i386/i386/Satellite/servletapi4-4.0.4-3jpp_5rh.noarch.rpm
  
Actual results:

The same file (same name and all).

Expected results:

The files should not be the same.

Additional info:
Comment 1 Jan Pazdziora 2008-10-13 05:50:22 EDT
On Satellite 5.2.0 on RHEL 5, no package requires servletapi4:

# rpm -e servletapi4-4.0.4-3jpp_5rh.noarch
#

I've restarted the Satellite and the WebUI continues to work normally.

So my assumption is that the package can be removed from Satellite 5.2.0 RHEL 5 compose.
Comment 2 Jan Pazdziora 2008-10-13 11:52:14 EDT
Checking in comps-rhel5-rhnsat52.xml;
/cvs/devel/comps/comps-rhel5-rhnsat52.xml,v  <--  comps-rhel5-rhnsat52.xml
new revision: 1.28; previous revision: 1.27
done
Comment 3 Jan Pazdziora 2008-10-14 07:30:23 EDT
New composes Satellite-5.2.0-RHEL4-re20081014.1 and Satellite-5.2.0-RHEL5-re20081014.1 were made, moving ON_QA.
Comment 4 Preethi Thomas 2008-10-15 10:46:48 EDT
verified
Comment 5 wes hayutin 2008-10-23 12:01:37 EDT
removed from the rhel 5 trees
release pending
Comment 6 Brandon Perkins 2008-11-05 13:42:43 EST
5.2.0 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.