Bug 466747 - On s390x, stty: standard input: Bad file descriptor
On s390x, stty: standard input: Bad file descriptor
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Milan Zázrivec
John Matthews
: Regression, Triaged
: 510754 (view as bug list)
Depends On:
Blocks: 456985 462714
  Show dependency treegraph
 
Reported: 2008-10-13 08:28 EDT by Milan Zázrivec
Modified: 2013-04-15 08:05 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:29:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zázrivec 2008-10-13 08:28:32 EDT
This bug reappeared in Satellite-5.3.0-RHEL5-re20080922.0
Seemingly the fix for the problem did not make it into spacewalk
and therefore Vader builds.

+++ This bug was initially created as a clone of Bug #454411 +++

Description of problem:

When running install of Satellite on s390x, I get

** Activating Satellite.
* Enabling Monitoring.
* Creating SSL certificates.
CA certificate password? stty: standard input: Bad file descriptor
stty: standard input: Bad file descriptor

Those stty messages do not seem correct, and the password is shown.

Version-Release number of selected component (if applicable):

Satellite-5.2.0-RHEL4-re20080704.0

How reproducible:

Tried once.

Steps to Reproduce:
1. Run ./install.pl --disconnected
  
Actual results:

** Activating Satellite.
* Enabling Monitoring.
* Creating SSL certificates.
CA certificate password? stty: standard input: Bad file descriptor
stty: standard input: Bad file descriptor

and password is shown as it is typed.

Expected results:

** Activating Satellite.
* Enabling Monitoring.
* Creating SSL certificates.
CA certificate password?
Re-enter CA certificate password?

No warning and no password shown.

Additional info:

--- Additional comment from mzazrivec@redhat.com on 2008-07-09 10:25:15 EDT ---

Sending        install/stage2.pl
Transmitting file data .
Committed revision 174908.

--- Additional comment from mmraka@redhat.com on 2008-07-24 05:33:21 EDT ---

Ported to RELEASE-5.2, r175400.

--- Additional comment from bbuckingham@redhat.com on 2008-08-13 12:52:29 EDT ---

Mass move to ON_QA.

--- Additional comment from ssalevan@redhat.com on 2008-09-02 11:58:34 EDT ---

Checked against RHEL4/5 s390x 520 ISOs; error message not seen and password not echoed to terminal.  Moving to VERIFIED.
Comment 1 Milan Zázrivec 2008-10-14 08:39:27 EDT
status -> modified
spacewalk git commit: 3627e5750dd7d780bf36e1955b0704fab96c56a7
Comment 2 Milan Zázrivec 2009-01-06 04:14:00 EST
This error still shows in Satellite-5.3.0-RHEL5-re20081223.1
Comment 4 Milan Zázrivec 2009-03-24 07:14:45 EDT
spacewalk.git master: c7d6fc215e9874b3defc6f8f83b428002b9f6e0e
Comment 5 Milan Zázrivec 2009-04-09 09:07:52 EDT
Fix present in spacewalk-setup-0.5.27-2 or Satellite-5.3.0-RHEL5-re20090403.2.
Comment 6 John Matthews 2009-06-26 17:25:08 EDT
Installed ISO Satellite-5.3.0-RHEL5-re20090625.0-s390x-embedded-oracle.iso

I entered the CA cert password, it worked as expected.

VERIFIED
Comment 8 Petr Sklenar 2009-09-02 10:08:50 EDT
I didnt see any stty error:
tried: Satellite-5.3.0-RHEL4-re20090820.1/tree-s390x/

* Creating SSL certificates.
CA certificate password? 
Re-enter CA certificate password? 
Organization? redhat
Comment 9 Brandon Perkins 2009-09-10 16:29:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html
Comment 10 Jan Pazdziora 2013-04-15 08:05:34 EDT
*** Bug 510754 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.