Bug 466755 - Licensing issues with included glew sources
Licensing issues with included glew sources
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: blender (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 09:22 EDT by Alexey Torkhov
Modified: 2008-10-15 11:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 11:30:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Torkhov 2008-10-13 09:22:37 EDT
Description of problem:
Blender under extern/glew carries a copy of glew sources. There are two problems with them:

1. Docs have "This documentation may not be modified or redistributed in any form, except by the copyright holder." statement. So they are definitely should be excluded. Upstream should be notified too.

2. glxew.h is partially licensed under GLX Public License Version 1.0. This license is not acceptable for fedora.

As blender uses non-modified version of (old) glew, the best and right solution will be to link it against system glew package - it doesn't have any license problems.

Version-Release number of selected component (if applicable):
blender-2.47-1.fc9.i386
Comment 1 Jochen Schmitt 2008-10-14 10:56:06 EDT
On

http://projects.blender.org/tracker/?func=detail&aid=17831&group_id=9&atid=264

upstream wrote, this is a more cosmetic issue which should be fixed in a upcomming release of blender (not 2.48).
Comment 2 Alexey Torkhov 2008-10-14 14:35:54 EDT
As upstream write (had to register to read it):
"""
This is a very cosmetic issue... the code has been in svn for
years! The GLX license was recently updated by SGI, which makes
this issue even more academical:

http://www.fsf.org/news/thank-you-sgi

Of course we'll happily upgrade glew, and remove non-gpl docs.
But not without a good testing period, which better not be done
right now (2.48 release freeze). Will put on todo for later.
Thanks!
"""

First, I think, no legal or licensing issue could be considered "cosmetic" in Fedora. And, after discovered, it should be fixed as soon as possible.

Second, about "GLX license was recently updated by SGI" -
SGI didn't make new version of GLX license nor they can, as I understand it doesn't have upgrade clause like SGI Free License B. Check here, for example:
http://www.fsf.org/blogs/licensing/2008-09-sgi-announcement
(I'm not whining about FreeB license - it is really free and acceptable now).

And last, upgrading glew perhaps needs some testing period. But, glew docs should not be used in any feature and could be simply removed? Are they?
Comment 3 Alexey Torkhov 2008-10-14 14:50:39 EDT
Oh, and you skipped a question about that blender should be linked to system version of glew - this would be right solution for a package.
Comment 4 Jochen Schmitt 2008-10-14 14:54:39 EDT
Ok, we may remove the glew documentation, but leave the license text files in this directory. I think this should be Ok.
Comment 5 Jochen Schmitt 2008-10-14 14:55:37 EDT
(In reply to comment #3)
> Oh, and you skipped a question about that blender should be linked to system
> version of glew - this would be right solution for a package.

Unfortunately, my first try failed.
Comment 6 Alexey Torkhov 2008-10-14 15:22:29 EDT
(In reply to comment #4)
> Ok, we may remove the glew documentation, but leave the license text files in
> this directory. I think this should be Ok.

May be, but at first we should try to avoid using bundled glew (and all other packaged libs too - I see qhull is also available as a package).

I don't know much about how SConstruct works, but I think, removing glew from compilation and adding -lGLEW as LDFLAGS where it is used or globally will be sufficient.
Comment 7 Jochen Schmitt 2008-10-14 15:31:00 EDT
I have find out, how I can build agains the system library, but blender crashed during the start up phase:

intern/ghost/intern/GHOST_WindowX11.cpp:175: X11 glxChooseVisual() failed for OpenGL, verify working openGL system!
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Resource id in failed request:  0x66900
  Serial number of failed request:  11
  Current serial number in output stream:  12
Comment 8 Jochen Schmitt 2008-10-15 11:30:25 EDT
I have found the issue for this failure and I was able to build blender-2.47-6.fc10 on rawhide agains system glew library.

Because, I'm afreid, that this change make break existing installations, we should release this modification only to rawhide and the upcoming F-10.

Note You need to log in before you can comment on or make changes to this bug.