Bug 466765 - Need 5.3 Release note on iSCSI behavior change
Need 5.3 Release note on iSCSI behavior change
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation (Show other bugs)
5.3
All Linux
high Severity medium
: rc
: ---
Assigned To: Ryan Lerch
Joshua Wulf
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 10:26 EDT by Denise Dumas
Modified: 2014-10-19 18:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Red Hat Enterprise Linux 5.3 now fully supports the iSCSI Boot Firmware Table (iBFT) which allows for booting from iSCSI devices. This support required that iSCSI disks (nodes) are no longer marked to start up automatically; the installed system will no longer automatically connect and login to iSCSI disks when entering runlevel 3 or 5. iSCSI is usually used for the root filesystem, in which case this change does does not make a difference as the initrd will connect and login to the needed iSCSI disks even before the runlevel is entered. However if iSCSI disks need to be mounted on non root directories, for example /home or /srv, then this change will impact you, since the installed system will no longer automatically connect and login to iSCSI disks which are not used for the root filesystem. Using iSCSI disks mounted on non root directories is still possible, but requires the use of one of the following workarounds: 1. Install the system without use of iSCSI disks mounted on non root directories and later configure the relevant disks and mount points manually 2. Boot the installed system into runlevel 1, and mark any iSCSI disks *which are not used for the root filesystem* for automatic startup by using the following command once per disk: iscsiadm -m node -T target-name -p ip:port -o update -n node.startup -v automatic
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 20:03:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denise Dumas 2008-10-13 10:26:56 EDT
Description of problem:

5.3 release note needed to document change in iCSI behavior, nottied to a particular BZ.

RHEL 5.3 supports the iSCSI Boot Firmware Table
(iBFT) which allows for booting from iSCSI devices. This support required that 
iSCSI disks (nodes) are no longer marked to startup automatically; the installed system will no longer automatically connect and login to iSCSI disks when entering runlevel 3 or 5.

iSCSI is usually used for the root ("/") filesystem, in which case this
change does does not make a difference as the initrd will connect and login
to the needed iSCSI disks even before the used runlevel is entered.

If however you want to have iSCSI disks mounted on non root directories, for
example /home or /src, then this change will impact you, since the installed
system will no longer automatically connect and login to iSCSI disks which
are not used for the root filesystem.

Using iSCSI disks mounted on non root directories is still possible, but
requires the use of one of two possible workarounds:

1) Install the system without use of iSCSI disks mounted on non root
directories and later configure the relevant disks and mount points manually

2) Boot the installed system into runlevel 1, and mark any
iSCSI disks *which are not used for the root filesystem* for automatic
startup by using the following command once per disk:
iscsiadm -m node -T <target-name> -p <ip:port> -o update -n node.startup -v automatic

If you do not know the target-names and / or ip:port you can get a list of
all nodes known to the system using: "iscsiadm -m node"


Version-Release number of selected component (if applicable):
5.3

How reproducible:
Comment 1 Denise Dumas 2008-10-13 10:27:31 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
5.3 release note needed to document change in iCSI behavior, nottied to a particular BZ.

RHEL 5.3 supports the iSCSI Boot Firmware Table
(iBFT) which allows for booting from iSCSI devices. This support required that 
iSCSI disks (nodes) are no longer marked to startup automatically; the
installed system will no longer automatically connect and login to iSCSI disks
when entering runlevel 3 or 5.

iSCSI is usually used for the root ("/") filesystem, in which case this
change does does not make a difference as the initrd will connect and login
to the needed iSCSI disks even before the used runlevel is entered.

If however you want to have iSCSI disks mounted on non root directories, for
example /home or /src, then this change will impact you, since the installed
system will no longer automatically connect and login to iSCSI disks which
are not used for the root filesystem.

Using iSCSI disks mounted on non root directories is still possible, but
requires the use of one of two possible workarounds:

1) Install the system without use of iSCSI disks mounted on non root
directories and later configure the relevant disks and mount points manually

2) Boot the installed system into runlevel 1, and mark any
iSCSI disks *which are not used for the root filesystem* for automatic
startup by using the following command once per disk:
iscsiadm -m node -T <target-name> -p <ip:port> -o update -n node.startup -v
automatic

If you do not know the target-names and / or ip:port you can get a list of
all nodes known to the system using: "iscsiadm -m node"
Comment 2 Hans de Goede 2008-10-13 10:44:13 EDT
I've got 2 small corrections:

1) iscsiadm -m node -T <target-name> -p <ip:port> -o update -n node.startup -v
automatic

This should be one line

2) /src should be /srv

This makes the new text:

RHEL 5.3 supports the iSCSI Boot Firmware Table
(iBFT) which allows for booting from iSCSI devices. This support required that 
iSCSI disks (nodes) are no longer marked to startup automatically; the
installed system will no longer automatically connect and login to iSCSI disks
when entering runlevel 3 or 5.

iSCSI is usually used for the root ("/") filesystem, in which case this
change does does not make a difference as the initrd will connect and login
to the needed iSCSI disks even before the used runlevel is entered.

If however you want to have iSCSI disks mounted on non root directories, for
example /home or /srv, then this change will impact you, since the installed
system will no longer automatically connect and login to iSCSI disks which
are not used for the root filesystem.

Using iSCSI disks mounted on non root directories is still possible, but
requires the use of one of two possible workarounds:

1) Install the system without use of iSCSI disks mounted on non root
directories and later configure the relevant disks and mount points manually

2) Boot the installed system into runlevel 1, and mark any
iSCSI disks *which are not used for the root filesystem* for automatic
startup by using the following command once per disk:
iscsiadm -m node -T <target-name> -p <ip:port> -o update -n node.startup -v automatic

If you do not know the target-names and / or ip:port you can get a list of
all nodes known to the system using: "iscsiadm -m node"
Comment 3 Ryan Lerch 2008-10-13 17:55:55 EDT
Should i document this one in the Known Issues section?
Comment 4 Hans de Goede 2008-10-14 03:31:40 EDT
(In reply to comment #3)
> Should i document this one in the Known Issues section?

With the disclaimer that I'm new the the whole RelNotes process, "Known Issues" seems to describe this pretty accurate.

Also can you please make sure that:
"iscsiadm -m node -T <target-name> -p <ip:port> -o update -n node.startup -v
automatic"

Gets in there as 1 line, I tried to make it 1 line in comment 2, but bugzilla and/or firefox keep insisting on cutting it in 2 lines.
Comment 5 Hans de Goede 2008-10-14 03:32:11 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -11,7 +11,7 @@
 to the needed iSCSI disks even before the used runlevel is entered.
 
 If however you want to have iSCSI disks mounted on non root directories, for
-example /home or /src, then this change will impact you, since the installed
+example /home or /srv, then this change will impact you, since the installed
 system will no longer automatically connect and login to iSCSI disks which
 are not used for the root filesystem.
 
@@ -24,8 +24,7 @@
 2) Boot the installed system into runlevel 1, and mark any
 iSCSI disks *which are not used for the root filesystem* for automatic
 startup by using the following command once per disk:
-iscsiadm -m node -T <target-name> -p <ip:port> -o update -n node.startup -v
-automatic
+iscsiadm -m node -T <target-name> -p <ip:port> -o update -n node.startup -v automatic
 
 If you do not know the target-names and / or ip:port you can get a list of
 all nodes known to the system using: "iscsiadm -m node"
Comment 6 Denise Dumas 2008-10-14 10:31:02 EDT
Hi Ryan,

I'm not sure where this should go - it's not really an Issue, it's more of a change of default behavior. Maybe we should also get it into the Install Guide?
Denise
Comment 8 Ryan Lerch 2008-10-26 22:01:00 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,23 +1,11 @@
-5.3 release note needed to document change in iCSI behavior, nottied to a particular BZ.
+Red Hat Enterprise Linux 5.3 now fully supports the iSCSI Boot Firmware Table (iBFT) which allows for booting from iSCSI devices. This support required that iSCSI disks (nodes) are no longer marked to start up automatically; the installed system will no longer automatically connect and login to iSCSI disks when entering runlevel 3 or 5.
 
-RHEL 5.3 supports the iSCSI Boot Firmware Table
-(iBFT) which allows for booting from iSCSI devices. This support required that 
-iSCSI disks (nodes) are no longer marked to startup automatically; the
-installed system will no longer automatically connect and login to iSCSI disks
-when entering runlevel 3 or 5.
+iSCSI is usually used for the root ("/") filesystem, in which case this change does does not make a difference as the initrd will connect and login to the needed iSCSI disks even before the used runlevel is entered.
 
-iSCSI is usually used for the root ("/") filesystem, in which case this
-change does does not make a difference as the initrd will connect and login
-to the needed iSCSI disks even before the used runlevel is entered.
+If however you want to have iSCSI disks mounted on non root directories, for example /home or /srv, then this change will impact you, since the installed system will no longer automatically connect and login to iSCSI disks which are not used for the root filesystem.
 
-If however you want to have iSCSI disks mounted on non root directories, for
-example /home or /srv, then this change will impact you, since the installed
-system will no longer automatically connect and login to iSCSI disks which
-are not used for the root filesystem.
+Using iSCSI disks mounted on non root directories is still possible, but requires the use of one of two possible workarounds:
 
-Using iSCSI disks mounted on non root directories is still possible, but
-requires the use of one of two possible workarounds:
-
 1) Install the system without use of iSCSI disks mounted on non root
 directories and later configure the relevant disks and mount points manually
 
@@ -26,5 +14,4 @@
 startup by using the following command once per disk:
 iscsiadm -m node -T <target-name> -p <ip:port> -o update -n node.startup -v automatic
 
-If you do not know the target-names and / or ip:port you can get a list of
+If you do not know the target-names and / or ip:port you can get a list of all nodes known to the system using: "iscsiadm -m node"-all nodes known to the system using: "iscsiadm -m node"
Comment 9 Ryan Lerch 2008-10-26 22:55:27 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,17 +1,12 @@
 Red Hat Enterprise Linux 5.3 now fully supports the iSCSI Boot Firmware Table (iBFT) which allows for booting from iSCSI devices. This support required that iSCSI disks (nodes) are no longer marked to start up automatically; the installed system will no longer automatically connect and login to iSCSI disks when entering runlevel 3 or 5.
 
-iSCSI is usually used for the root ("/") filesystem, in which case this change does does not make a difference as the initrd will connect and login to the needed iSCSI disks even before the used runlevel is entered.
+iSCSI is usually used for the root filesystem, in which case this change does does not make a difference as the initrd will connect and login to the needed iSCSI disks even before the runlevel is entered.
 
-If however you want to have iSCSI disks mounted on non root directories, for example /home or /srv, then this change will impact you, since the installed system will no longer automatically connect and login to iSCSI disks which are not used for the root filesystem.
+However if iSCSI disks need to be mounted on non root directories, for example /home or /srv, then this change will impact you, since the installed system will no longer automatically connect and login to iSCSI disks which are not used for the root filesystem.
 
-Using iSCSI disks mounted on non root directories is still possible, but requires the use of one of two possible workarounds:
+Using iSCSI disks mounted on non root directories is still possible, but requires the use of one of the following workarounds:
 
-1) Install the system without use of iSCSI disks mounted on non root
-directories and later configure the relevant disks and mount points manually
+1. Install the system without use of iSCSI disks mounted on non root directories and later configure the relevant disks and mount points manually
 
-2) Boot the installed system into runlevel 1, and mark any
+2. Boot the installed system into runlevel 1, and mark any iSCSI disks *which are not used for the root filesystem* for automatic startup by using the following command once per disk:
-iSCSI disks *which are not used for the root filesystem* for automatic
+iscsiadm -m node -T target-name -p ip:port -o update -n node.startup -v automatic-startup by using the following command once per disk:
-iscsiadm -m node -T <target-name> -p <ip:port> -o update -n node.startup -v automatic
-
-If you do not know the target-names and / or ip:port you can get a list of all nodes known to the system using: "iscsiadm -m node"
Comment 11 Ryan Lerch 2010-04-20 20:34:16 EDT
This note is located here:

http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html-single/Release_Notes/#sect-Release_Notes-Feature_Updates

Under the header
"iSCSI Boot Firmware Table"
Comment 12 Andrew Ross 2010-04-20 20:41:40 EDT
Verified content including comment #2

<snip>
1) iscsiadm -m node -T <target-name> -p <ip:port> -o update -n node.startup -v
automatic

This should be one line

2) /src should be /srv
</snip>


Red_Hat_Enterprise_Linux-Release_Notes-5.3-en-US-3-2
Comment 13 Andrew Ross 2010-06-03 20:03:36 EDT
Live: Red_Hat_Enterprise_Linux-Release_Notes-5.3-web-en-US-3-2.el5

Note You need to log in before you can comment on or make changes to this bug.