Bug 466813 - livecd-creator ignores xconfig --defaultdesktop parameter
livecd-creator ignores xconfig --defaultdesktop parameter
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 15:21 EDT by Orion Poplawski
Modified: 2008-10-17 09:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-17 09:11:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Support --defaultdesktop (1.13 KB, patch)
2008-10-14 16:44 EDT, Orion Poplawski
no flags Details | Diff

  None (edit)
Description Orion Poplawski 2008-10-13 15:21:07 EDT
Description of problem:

livecd-creator ignores xconfig --defaultdesktop parameter

I have:

xconfig --startxonboot --defaultdesktop=KDE

but no /etc/sysconfig/desktop file is written.

Version-Release number of selected component (if applicable):
019-1.fc10
Comment 1 Jeremy Katz 2008-10-14 12:46:47 EDT
Accepting patches :-)   Or I'll get to it eventually
Comment 2 Orion Poplawski 2008-10-14 16:44:42 EDT
Created attachment 320352 [details]
Support --defaultdesktop

This works for me, and seems pretty comparable to the code in anaconda.
Comment 3 Jeremy Katz 2008-10-17 09:11:42 EDT
Thanks, applied and pushed.  And there will be another livecd-tools build before F10 final

Note You need to log in before you can comment on or make changes to this bug.