Bug 466827 - [RFE] yum: When yum removes a package, ensure that the package architecture(s) is/are written to the yum log.
[RFE] yum: When yum removes a package, ensure that the package architecture(s...
Status: CLOSED DUPLICATE of bug 198265
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-10-13 17:42 EDT by Stuart R. Kirk
Modified: 2014-01-21 18:06 EST (History)
6 users (show)

See Also:
Fixed In Version: h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-10-14 01:08:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stuart R. Kirk 2008-10-13 17:42:51 EDT
Description of problem:
Given a system installed with any current Fedora or RHEL distribution, when executing a "yum remove <packagename>" on a particular package, the following statement is generated in the configured yum.log file:

<date> <time> Erased: <packagename>

Where the removed package is of a singular architecture (ex. i386, x86_64, etc) the information written to the yum.log as stated above is for the most part sufficient.  However, if a package is installed with multiple architectures, and a "yum remove <packagename>" is executed without specifying an architecture, rather than the yum.log stating that two packages of different architectures were removed, the following is displayed instead:

<date> <time> Erased: <packagename>
<date> <time> Erased: <packagename>

As such, this is quite confusing for users that do not understand that multiple architectures can be present on a system at any one time.  I would like to request that for all packages removed, yum lists the architecture of the package removed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install RHEL / Fedora
2. tail -f /path/to/your/yum.log
3. yum remove <package>
4. Observe that only the package name, not architecture, is written to the log.
Actual results:
Only the package name that is being removed, along with the date and time are logged, not the architecture.

Expected results:

Additional info:
Comment 1 seth vidal 2008-10-13 21:11:19 EDT
Rpm only returns package name on an erasure in the transaction. 

Comment 2 James Antill 2008-10-13 23:36:02 EDT
 This is also related to:


...which was closed for the same reason.
Comment 3 Stuart R. Kirk 2008-10-14 01:08:06 EDT

*** This bug has been marked as a duplicate of bug 198265 ***
Comment 4 seth vidal 2009-07-20 16:33:50 EDT
What does setting "Customer Verified" have to do with this bug?

Note You need to log in before you can comment on or make changes to this bug.