Bug 466845 - [PATCH] Change "unkn-4" to "probe0" in status of "netstat -o"
[PATCH] Change "unkn-4" to "probe0" in status of "netstat -o"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-tools (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jiri Popelka
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 01:45 EDT by Masaki MAENO
Modified: 2013-04-12 15:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-16 04:27:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
net-tools package patch for probe0 timer working status (568 bytes, patch)
2008-10-14 01:45 EDT, Masaki MAENO
no flags Details | Diff

  None (edit)
Description Masaki MAENO 2008-10-14 01:45:28 EDT
Created attachment 320253 [details]
net-tools package patch for probe0 timer working status

Description of problem:
The display of "netstat -o" (on|off|keepalive|unkn-X) is not accurate. 
I think that "unkn-4" should be "probe0" that is working "probe0 timer 
(= ICSK_TIME_PROBE0 status = TCP Window Size is Zero) " in kernel.

Version-Release number of selected component (if applicable):
net-tools all version

How reproducible:
When TCP Window Size is zero (= network load is high), execute "netstat -o".
  
Actual results:
$ netstat -atno 
...
tcp        0      0 172.17.0.157:46124          172.19.0.2:22               ESTABLISHED keepalive (3871.19/0/0)
tcp        0      0 172.17.0.157:33733          172.17.0.156:445            ESTABLISHED off (0.00/0/0)
tcp        0      0 172.17.0.157:34300          172.20.128.2:22             ESTABLISHED unkn-4 (3871.19/0/0)
tcp        0      0 172.17.0.157:32903          172.20.128.2:22             ESTABLISHED keepalive (3871.19/0/0)
tcp        0      0 172.17.0.157:40209          172.19.0.2:143              ESTABLISHED off (0.00/0/0)
tcp        0      0 172.17.0.157:445            172.17.1.13:1029            ESTABLISHED keepalive (1342.25/0/0)
...

Expected results:
$ netstat -atno 
...
tcp        0      0 172.17.0.157:46124          172.19.0.2:22               ESTABLISHED keepalive (3871.19/0/0)
tcp        0      0 172.17.0.157:33733          172.17.0.156:445            ESTABLISHED off (0.00/0/0)
tcp        0      0 172.17.0.157:34300          172.20.128.2:22             ESTABLISHED probe0 (3871.19/0/0)
tcp        0      0 172.17.0.157:32903          172.20.128.2:22             ESTABLISHED keepalive (3871.19/0/0)
tcp        0      0 172.17.0.157:40209          172.19.0.2:143              ESTABLISHED off (0.00/0/0)
tcp        0      0 172.17.0.157:445            172.17.1.13:1029            ESTABLISHED keepalive (1342.25/0/0)
...
Comment 1 Zdenek Prikryl 2008-10-15 02:45:32 EDT
Seems reasonable, I'll use only "probe" instead of "probe0", because '0' could be confusing for other users.
Comment 2 Masaki MAENO 2008-10-15 03:01:08 EDT
OK. Please use "probe".
Comment 4 RHEL Product and Program Management 2009-03-26 13:09:23 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 RHEL Product and Program Management 2009-11-06 14:21:38 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 11 errata-xmlrpc 2009-12-16 04:27:06 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1677.html

Note You need to log in before you can comment on or make changes to this bug.