Bug 466847 - compiz hangs system on Fire GL 3100 PCIE
compiz hangs system on Fire GL 3100 PCIE
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 01:56 EDT by David
Modified: 2008-12-19 18:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 18:56:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log with no xorg.conf (126.69 KB, text/plain)
2008-10-31 09:32 EDT, David
no flags Details

  None (edit)
Description David 2008-10-14 01:56:57 EDT
Description of problem:
After running with desktop effects for a few seconds, the computer froze
completely.

http://www.smolts.org/client/show/pub_d49c89b4-8ca6-4c42-9edf-2d7ab3532390

Version-Release number of selected component (if applicable):


How reproducible:
5 times out of 5 tries on my computer

Steps to Reproduce:
1. Enable desktop effects

Actual results:
System hangs.

Expected results:
Doesn't hang.

Additional info:
Comment 1 Matěj Cepl 2008-10-27 07:06:00 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 David 2008-10-27 11:09:57 EDT
I will try to get this information, but I ended up having to uninstall compiz
to get my system stable again after enabling desktop effects.  Even though
desktop effects were enabled, the desktop-effects gui didn't have a "disable"
button... it still had an enable button.  And my system was freezing in X
pretty quickly.  So I booted into run level 3 and yum uninstalled compiz.
I'll re-install it, but can somebody tell me the COMMAND LINE way to disable
desktop effects.  

Actually, now that I look at the requested information, it's not clear to 
me that I need to re-install compiz to provide the requested information.  
Do you want the X logs with compiz enabled or does it not matter?
Comment 3 Matěj Cepl 2008-10-27 13:46:57 EDT
Concerning desktop-effects -- just click "Enable" button again -- when it is "clicked out" desktop effects are switched off.

Concerning logs, no, it doesn't matter that much whether you have compiz enabled or not. If we need backtrace from crashing compiz, we will ask for it.
Comment 4 David 2008-10-31 09:32:23 EDT
Created attachment 322052 [details]
Xorg.0.log with no xorg.conf

There seems to be no xorg.conf on my system, so this is the only requested file that I can provide.
Comment 5 David 2008-10-31 09:35:54 EDT
(In reply to comment #3)
> Concerning desktop-effects -- just click "Enable" button again -- when it is
> "clicked out" desktop effects are switched off.

It is hard to click Enable again since X hangs.  How do I disable desktop-effects from the COMMAND LINE (so I can boot to runlevel 3 and disable them).
Comment 6 Matěj Cepl 2008-10-31 12:08:50 EDT
(In reply to comment #5)
> (In reply to comment #3)
> > Concerning desktop-effects -- just click "Enable" button again -- when it is
> > "clicked out" desktop effects are switched off.
> 
> It is hard to click Enable again since X hangs.  How do I disable
> desktop-effects from the COMMAND LINE (so I can boot to runlevel 3 and disable
> them).

gconftool-2 --type string --set /apps/gnome-session/rh/window_manager "metacity"
Comment 7 Matěj Cepl 2008-10-31 12:09:20 EDT
... and it is per-user setting, so don't do it as root
Comment 8 Bug Zapper 2008-11-25 22:50:44 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Jóhann B. Guðmundsson 2008-12-01 06:45:22 EST
There have been bunch of bug fixes

Could you retest with the latest kernel 
( -132 at the time of this writing )

You can get the latest kernel build here
http://koji.fedoraproject.org/koji/buildinfo?buildID=72270 

And with the latest xorg-x11-drv-ati. 
( -60 at the time of this writing )

You can get the latest xorg-x11-drv-ati build here
http://koji.fedoraproject.org/koji/packageinfo?packageID=95

And report back if it either improves or fixes this issue..

Thanks.
Comment 10 David 2008-12-17 15:30:40 EST
I can't figure out how to re-anable desktop effects.  I previously uninstalled compiz, but I have re-installed it now.  I don't find the enable desktop effects setting in the system->preferences where I thought it used to be.  I tried enabling it from the command line like this:

gconftool-2 --type string --set /apps/gnome-session/rh/window_manager "compiz"

But that didn't seem to do anything.

On a related note, my X is hanging with the new driver even when I don't enable compiz.  I'm using xorg-x11-drv-ati.i386 6.9.0-61.fc10.
Comment 11 Matěj Cepl 2008-12-18 04:17:59 EST
Try to run desktop-effects command from gnome-terminal.

[matej@viklef ~]$ rpm -qf $(which desktop-effects)
compiz-gnome-0.7.8-4.fc10.i386
[matej@viklef ~]$

Does it help?
Comment 12 David 2008-12-18 10:18:57 EST
I ended up doing a complete re-install of f10 yesterday because my f10 partition was corrupted ... fsck didn't fix it (but it thought it fixed it).  Anyway, after the re-install and an update, the desktop effects setting re-appeared in the
system->preferences menu.  I tried it briefly and it didn't hang my system during
the short test (I didn't use it for longer because the title bars were missing).
So I think the original bug is fixed, so I guess this bug can be closed.  I'll
re-open it if I see the problem again.
Comment 13 Matěj Cepl 2008-12-19 18:56:56 EST
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.