This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 466855 - [5.3] Kdump Not Work on ibm-qs22
[5.3] Kdump Not Work on ibm-qs22
Status: CLOSED DUPLICATE of bug 426293
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
ppc64 Linux
low Severity low
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 02:54 EDT by CAI Qian
Modified: 2009-09-09 01:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 07:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2008-10-14 02:54:20 EDT
Description of problem:
Kdump Kernel could hang or reset,

ibm-qs22-01.lab.bos.redhat.com login: SysRq : Trigger a crashdump
Sending IPI to other cpus...
Starting Linux PPC64 #1 SMP Tue Apr 29 13:56:48 EDT 2008
-----------------------------------------------------
ppc64_pft_size                = 0x0
physicalMemorySize            = 0x12010000
ppc64_caches.dcache_line_size = 0x80
ppc64_caches.icache_line_size = 0x80
htab_address                  = 0xc000000011800000
htab_hash_mask                = 0xffff
physical_start                = 0x2000000
-----------------------------------------------------
Linux version 2.6.18-92.el5kdump (brewbuilder@js20-bc1-11.build.redhat.com) (gcc version 4.1.2 20071124 (Red Hat 4.1.2-41)) #1 SMP Tue Apr 29 13:56:48 EDT 2008
*** 0000 : CF000012

*** 0000 : Setup Arch
[boot]0012 Setup Arch
mmio NVRAM, 1020k at 0x14502000000 mapped to d000080080070000
*** 0000 : CF000015

*** 0000 : Setup Done
[boot]0015 Setup Done
Built 2 zonelists.  Total pages: 4609
Kernel command line: root=/dev/VolGroup00/LogVol00 ro console=ttyS0,19200  irqpoll maxcpus=1 noirqdistrib reset_devices elfcorehdr=39744K savemaxmem=32768M 
Misrouted IRQ fixup and polling support enabled
This may significantly impact system performance
IIC for CPU 0 target id 0xe : /be@20000000000/interrupt-controller@508400
IIC for CPU 1 target id 0xf : /be@20000000000/interrupt-controller@508400
IIC for CPU 2 target id 0x1e : /be@20100000000/interrupt-controller@508400
IIC for CPU 3 target id 0x1f : /be@20100000000/interrupt-controller@508400
mpic: Setting up MPIC " MPIC     " version 1.2 at 0, max 4 CPUs
mpic: ISU size: 128, shift: 7, mask: 7f
mpic: Initializing for 128 sources
/axon@10000000000/interrupt-controller : hooking up to IRQ 43
mpic: Setting up MPIC " MPIC     " version 1.2 at 0, max 4 CPUs
mpic: ISU size: 128, shift: 7, mask: 7f
mpic: Initializing for 128 sources
/axon@30000000000/interrupt-controller : hooking up to IRQ 299
PID hash table entries: 2048 (order: 11, 16384 bytes)
Using Cell machine description
Found initrd at 0xc0000000026f0000:0xc000000002a20000
Starting Linux PPC64 #1 SMP Tue Apr 29 13:56:48 EDT 2008
-----------------------------------------------------
ppc64_pft_size                = 0x0
physicalMemorySize            = 0x12010000
ppc64_caches.dcache_line_size = 0x80
ppc64_caches.icache_line_size = 0x80
htab_address                  = 0xc000000011800000
htab_hash_mask                = 0xffff
physical_start                = 0x2000000
-----------------------------------------------------
Linux version 2.6.18-92.el5kdump (brewbuilder@js20-bc1-11.build.redhat.com) (gcc version 4.1.2 20071124 (Red Hat 4.1.2-41)) #1 SMP Tue Apr 29 13:56:48 EDT 2008
*** 0000 : CF000012

*** 0000 : Setup Arch
[boot]0012 Setup Arch
mmio NVRAM, 1020k at 0x14502000000 mapped to d000080080070000
*** 0000 : CF000015

*** 0000 : Setup Done
[boot]0015 Setup Done
Built 2 zonelists.  Total pages: 4609
Kernel command line: root=/dev/VolGroup00/LogVol00 ro console=ttyS0,19200  irqpoll maxcpus=1 noirqdistrib reset_devices elfcorehdr=39744K savemaxmem=32768M 
Misrouted IRQ fixup and polling support enabled
This may significantly impact system performance
IIC for CPU 0 target id 0xe : /be@20000000000/interrupt-controller@508400
IIC for CPU 1 target id 0xf : /be@20000000000/interrupt-controller@508400
IIC for CPU 2 target id 0x1e : /be@20100000000/interrupt-controller@508400
IIC for CPU 3 target id 0x1f : /be@20100000000/interrupt-controller@508400
mpic: Setting up MPIC " MPIC     " version 1.2 at 0, max 4 CPUs
mpic: ISU size: 128, shift: 7, mask: 7f
mpic: Initializing for 128 sources
/axon@10000000000/interrupt-controller : hooking up to IRQ 43
mpic: Setting up MPIC " MPIC     " version 1.2 at 0, max 4 CPUs
mpic: ISU size: 128, shift: 7, mask: 7f
mpic: Initializing for 128 sources
/axon@30000000000/interrupt-controller : hooking up to IRQ 299
PID hash table entries: 2048 (order: 11, 16384 bytes)
Console: colour dummy device 80x25
Dentry cache hash table entries: 65536 (order: 3, 524288 bytes)
Inode-cache hash table entries: 32768 (order: 2, 262144 bytes)
freeing bootmem node 0
Memory: 241856k/294976k available (4352k kernel code, 53120k reserved, 1280k data, 841k bss, 320k init)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 4096
Brought up 1 CPUs
checking if image is initramfs... it is
Freeing initrd memory: 3264k freed
NET: Registered protocol family 16
*** 0000 : Linux ppc64

*** 0000 : 2.6.18-92.el5kdump
iommu: disabled, direct DMA offset is 0x0
irq: no irq host found for /axon@10000000000/plb5/pciex-utl@a00000a000004000 !
irq: no irq host found for /axon@10000000000/plb5/pciex-utl@a00000a200004000 !
irq: no irq host found for /axon@30000000000/plb5/pciex-utl@a00000a000004000 !
irq: no irq host found for /axon@30000000000/plb5/pciex-utl@a00000a200004000 !
No pciex nodes found
No pcix nodes found
usbcore: registered new driver usbfs
usbcore: registered new driver hub
NetLabel: Initializing
NetLabel:  domain hash size = 128
NetLabel:  protocols = UNLABELED CIPSOv4
NetLabel:  unlabeled traffic allowed by default
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: -1, 32768 bytes)
TCP established hash table entries: 16384 (order: 2, 262144 bytes)
TCP bind hash table entries: 8192 (order: 1, 131072 bytes)
TCP: Hash tables configured (established 16384 bind 8192)
TCP reno registered
IBM eBus Device Driver
scan-log-dump not implemented on this system
audit: initializing netlink socket (disabled)
audit(1223966960.593:1): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 8192 (order 0, 65536 bytes)
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key DAA8D2EFA77BA785
- User ID: Red Hat, Inc. (Kernel Module GPG key)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
assign_interrupt_mode Found MSI capability
assign_interrupt_mode Found MSI capability
assign_interrupt_mode Found MSI capability
assign_interrupt_mode Found MSI capability
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
rpaphp: RPA HOT Plug PCI Controller Driver version: 0.1
rpadlpar_io_init: partition not DLPAR capable
Generic RTC Driver v1.07
Linux agpgart interface v0.101 (c) Dave Jones
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
serial8250.0: ttyS0 at MMIO 0x14540000200 (irq = 16) is a 16550A
serial8250.0: ttyS1 at MMIO 0x14540000300 (irq = 17) is a 16550A
serial8250.0: ttyS2 at MMIO 0x34540000200 (irq = 18) is a 16550A
serial8250.0: ttyS3 at MMIO 0x34540000300 (irq = 19) is a 16550A
14540000200.serial: ttyS0 at MMIO 0x14540000200 (irq = 16) is a 16550A
14540000300.serial: ttyS1 at MMIO 0x14540000300 (irq = 17) is a 16550A
34540000200.serial: ttyS2 at MMIO 0x34540000200 (irq = 18) is a 16550A
34540000300.serial: ttyS3 at MMIO 0x34540000300 (irq = 19) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 16384K size 4096 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ide-floppy driver 0.99.newide
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
mice: PS/2 mouse device common for all mice
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
Freeing unused kernel memory: 320k freed
ehci_hcd 0005:00:01.2: EHCI Host Controller
ehci_hcd 0005:00:01.2: new USB bus registered, assigned bus number 1
ehci_hcd 0005:00:01.2: irq 36, io mem 0x34780002000
ehci_hcd 0005:00:01.2: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 5 ports detected
ohci_hcd 0005:00:01.0: OHCI Host Controller
ohci_hcd 0005:00:01.0: new USB bus registered, assigned bus number 2
ohci_hcd 0005:00:01.0: irq 36, io mem 0x34780000000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
usb 1-5: new high speed USB device using ehci_hcd and address 2
ohci_hcd 0005:00:01.1: OHCI Host Controller
ohci_hcd 0005:00:01.1: new USB bus registered, assigned bus number 3
ohci_hcd 0005:00:01.1: irq 36, io mem 0x34780001000
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
USB Universal Host Controller Interface driver v3.0
SCSI subsystem initialized
Initializing USB Mass Storage driver...
ehci_hcd 0005:00:01.2: Unlink after no-IRQ?  Controller is probably using the wrong IRQ.
hub 1-0:1.0: Cannot enable port 5.  Maybe the USB cable is bad?
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.11.5-ioctl (2007-12-12) initialised: dm-devel@redhat.com
<hang...>

Version-Release number of selected component (if applicable):
kernel-2.6.18-118.el5 and kernel-2.6.18-92.el5
kernel-kdump-2.6.18-118.el5 and kernel-kdump-2.6.18-92.el5
kexec-tools-1.102pre-46.el5 and kexec-tools-1.102pre-21.el5

How reproducible:
always

Steps to Reproduce:
1. reserve ibm-qs22-01.lab.bos.redhat.com
2. configure Kdump with crashkernel=256M@32M
3. SysRq-C
Comment 1 Neil Horman 2008-10-14 07:15:08 EDT

*** This bug has been marked as a duplicate of bug 426293 ***

Note You need to log in before you can comment on or make changes to this bug.